Metric Tutorials
This publication, or parts thereof, may not be reproduced in any form, by any method, for any purpose.

AUTODESK, INC. MAKES NO WARRANTY, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE REGARDING THESE MATERIALS, AND MAKES SUCH MATERIALS AVAILABLE SOLELY ON AN "AS-IS" BASIS. IN NO EVENT SHALL AUTODESK, INC., BE LIABLE TO ANYONE FOR SPECIAL, COLLATERAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES IN CONNECTION WITH OR ARISING OUT OF PURCHASE OR USE OF THESE MATERIALS. THE SOLE AND EXCLUSIVE LIABILITY TO AUTODESK, INC., REGARDLESS OF THE FORM OF ACTION, SHALL NOT EXCEED THE PURCHASE PRICE OF THE MATERIALS DESCRIBED HEREIN.

Autodesk, Inc., reserves the right to revise and improve its products as it sees fit. This publication describes the state cation, and may not reflect the product at all times in the future.

Autodesk Trademarks


The following are trademarks of Autodesk, Inc., in the USA and/or other countries: 3ds max, AutoCAD Architectural Desktop, AutoCAD Learning Assistance, AutoCAD LT Learning Assistance, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, Autodesk Map, Autodesk Streamline, AutoSnap, AutoTrack, Built with ObjectARX (logo), Burn, Buzzsaw, Buzzsaw.com, Cinestream, Cleaner, Cleaner Central, ClearScale, Colour Warner, Content Explorer, Dancing Baby (image), DesignCenter, Design Doctor, Designer's Toolkit, DesignProf, DesignServer, Design Web Format, DWF, DWG Linking, DXF, Extending the Design Team, GDX Driver, gmax (logo), gmax ready (logo), Heads-up Design, IntroDV, jobnet, ObjectDBX, onscreen onair online, Plans & Specs, Plasma, PolarSnap, ProjectPoint, Reactor, Real-time Roto, Render Queue, Visual Bridge, Visual Sylabus, and Where Design Connects.

Autodesk Canada Inc. Trademarks

The following are registered trademarks of Autodesk Canada Inc. in the USA and/or Canada, and/or other countries: discreet, fire, flame, flint, flint RT, frost, glass, inferno, MountStone, riot, river, smoke, sparks, stone, stream, vapour, wire.

The following are trademarks of Autodesk Canada Inc., in the USA, Canada, and/or other countries: backburner, backdraft, Multi-Master Editing.

Third Party Trademarks

All other brand names, product names or trademarks belong to their respective holders.

Third Party Software Program Credits

ACIS Copyright © 1989-2001 Spatial Corp. Portions Copyright © 2002 Autodesk, Inc.

Copyright © 1997 Microsoft Corporation. All rights reserved.

International CorrectSpell™ Spelling Correction System © 1995 by Lemont & Hauspie Speech Products, N.V. All rights reserved.

InstallShield™ 3.0. Copyright © 1997 InstallShield Software Corporation. All rights reserved.

PANTONE® Colors displayed in the software application or in the user documentation may not match PANTONE-identified standards. Consult current PANTONE Color Publications for accurate color. PANTONE® and other trademarks are the property of Pantone, Inc., © Pantone, Inc., 2002

Pantone, Inc. is the copyright owner of color data and/or software which are licensed to Autodesk, Inc., to distribute for use only in combination with certain Autodesk software products. PANTONE Color Data and/or Software shall not be copied onto another disk or into memory unless as part of the execution of this Autodesk software product.

Portions Copyright © 1991-1996 Arthur D. Applegate. All rights reserved.

Portions of this software are based on the work of the Independent JPEG Group.

RAL DESIGN ® RAL, Sankt Augustin, 2002

RAL CLASSIC ® RAL, Sankt Augustin, 2002

Representation of the RAL Colors is done with the approval of RAL Deutsches Institut für Gütesicherung und Kennzeichnung e.V. (RAL German Institute for Quality Assurance and Certification, re. Assoc.), D-53757 Sankt Augustin.

Typefaces from the Bitstream® typeface library copyright 1992. Typefaces from Payne Loving Trust © 1996. All rights reserved.

GOVERNMENT USE

Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 12.212 (Commercial Computer Software-Restricted Rights) and DFAR 227.7202 (Rights in Technical Data and Computer Software), as applicable.
# Contents

## Chapter 1 Introduction
- Using This Tutorial ................................................................. 1
- Printing the Tutorial ............................................................... 2
- Accessing the Tutorial Files and Datasets ............................... 2
- Extracting Datasets .................................................................. 2
- Learning VIZ Render 2006 ...................................................... 3
- Overview: Working in Architectural Desktop .......................... 3
- Designing with Objects ......................................................... 5
- Completing a Project .............................................................. 10
- Integrating VIZ Render in Your Project Workflow .................... 13
- Understanding the User Interface ......................................... 15
- The Workspace ..................................................................... 16
  - Title Bar ............................................................................. 17
  - Menu Bar .......................................................................... 17
  - Toolbars ........................................................................... 18
  - Drawing Window and Layout Tabs ....................................... 18
  - Context Menus .................................................................. 18
  - Drawing Window Status Bar ............................................. 19
  - Open Drawing Menu .......................................................... 19
  - Command Palette ............................................................. 20
  - Application Status Bar ....................................................... 20
- The Project Browser and Project Navigator Palette .................. 20
  - The Project Browser ........................................................... 20
  - Project Navigator Palette ................................................... 21
- Tools and Tool Palettes .......................................................... 22
  - The Properties Palette ....................................................... 24
- Content Browser ................................................................... 25
- DesignCenter ........................................................................ 26
- Detail Component Manager .................................................... 27
- Arranging Your Workspace .................................................... 27

## Chapter 2 Getting Started with Projects
- Understanding the Tutorial Project ....................................... 30
- Lesson 1: Setting up the Small Office Building Sample Project 30
  - Exercise 1: Exploring Project Drawings .................................. 30
  - Exercise 2: Creating a Set of Project Tools ............................ 37
- Lesson 2: Setting up Your Project Template ............................ 39
  - Exercise 1: Creating a Project Template .................................. 40
  - Exercise 2: Adding Legacy Drawings to the Project ............... 46
  - Exercise 3: Configure Project Standards ............................... 48
  - Exercise 4: Generate Project Tools from a Project Standards Drawing .................................................. 51
  - Exercise 5: Defining Building Levels ...................................... 53
  - Exercise 6: Categorizing Portions of Your Project ................ 54
  - Exercise 7: Creating a Project from a Project Template .......... 56
  - Exercise 8: Create the Core and Shell from a Sketch Using Tools .................................................. 56
- Lesson 3: Managing Project Standards ................................... 64
Chapter 3  Creating a Steel-Framed Residence ................................................................. 71
Understanding the Tutorial Project ........................................................................... 72
Opening and Exploring the Project ........................................................................... 74
Lesson 1: Developing the Steel-Framed Residence .................................................. 74
Exercise 1: Creating Connected and Trimmed Structural Members .................. 75
Exercise 2: Developing the Structural Frame from Linework .......................... 81
Exercise 3: Adding Braces to the Structural Frame ............................................. 86
Exercise 4: Creating Roof, Ceiling, and Floor Slabs ......................................... 90
Lesson 2: Creating a Roof Enclosure and a Screen .............................................. 95
Exercise 1: Creating Structural Members from a Roof Slab ............................. 96
Exercise 2: Trimming Structural Members ......................................................... 98
Exercise 3: Create an Array of Structural Members for a Screen ................... 100
Lesson 3: Sharing Design Data ............................................................................... 102
Exercise 1: Creating a Terrain Model ................................................................. 103
Exercise 2: Analyzing the Site for Flooding ....................................................... 110
Exercise 3: Creating Elevations for a Sheet ....................................................... 116
Exercise 4: Updating Elevations ......................................................................... 120
Exercise 5: Creating a Section for a Sheet ........................................................... 121
Exercise 6: Updating a Section ............................................................................ 125
Exercise 7: Publishing Model and Detail Views to 3D DWF .............................. 130
Lesson 4: Updating and Modifying Project Tools ............................................... 137
Exercise 1: Updating Project-Standard Tools ..................................................... 137
Exercise 2: Modifying Structural Member Tools ............................................... 139
Introduction

This tutorial shows you how you can use key features of Autodesk® Architectural Desktop to complete your architectural projects. By completing this tutorial, you learn how to use Architectural Desktop to:

■ facilitate the design of a small office building.
■ develop the design of a small steel-framed residence.
■ communicate your designs to others.
■ create automated construction documents from building models that include floor plans, sections, elevations, and annotation.

The tutorial contains two main sections that focus on the new features included in Architectural Desktop. In the first section, which focuses on creating a project, you work with a small office building dataset. In the second section, which focuses on creating trimmed and connected structural members, you work with a steel-framed residence dataset.

The lessons in the tutorial follow the typical workflow of an architectural project, from pre-design through creation and publication of construction documents. You can follow the workflow presented in these lessons when you start your own projects.
Using This Tutorial

In addition to this conceptual introduction, this tutorial contains two main sections that follow the workflow of an architectural project: Getting Started with Projects and Creating a Steel-Framed Residence.

Lessons in each of the tutorials contain step-by-step exercises focused on a tangible result. Project datasets that contain the exercise drawings that you work on are provided. Imperial project datasets are have an _I suffix and metric project datasets have an _M suffix. Within a project, exercise files have an X- prefix.

Depending on your level of experience with Autodesk Architectural Desktop, you may want to take a different approach to the tutorial:

- **If you are a new user**, begin by reading this introduction to familiarize yourself with the concepts of working in Architectural Desktop and the process of creating a building model. Then, complete each lesson in order.
  After you complete the tutorial, you can use the online Architectural Desktop User’s Guide or the printed Architectural Desktop 2006 Concepts Guide to learn more about Architectural Desktop.

- **If you are a previous user**, you may want to complete the only the lessons and exercises in this tutorial.
  You may also want to review the new feature documentation that you can access from the New Features Topic List in the online Architectural Desktop User’s Guide.

**AutoCAD Knowledge**: The lessons in this tutorial are designed to build upon your knowledge of AutoCAD®. If you are not familiar with basic AutoCAD functions and commands, see the online AutoCAD® 2006 User’s Guide.

Printing the Tutorial

If you want to print all or part of this tutorial, you can access and print the tutorial PDF, adt_mtut_2006.pdf, located on the product installation CD in root:\ADT\Docs.

To open, view, search, and print the PDF, you must have the free Adobe® Reader® installed on your system. You can download the Adobe Reader at http://www.adobe.com.

Accessing the Tutorial Files and Datasets

Project datasets for the tutorial are ready for installation. The datasets are located in c:\program files\autodesk architectural desktop 2006\tutorial\architectural desktop\datasets. By default, they install to my documents\autodesk\my projects. If you are using Architectural Desktop in a network environment, the tutorial files may be in a different location. Contact your network administrator or CAD manager for the location of the tutorial files.

Each lesson is a group of related exercises focused on a tangible result, such as setting up a new project, developing a design, or sharing your design data. Most lessons have corresponding datasets that contain the project files you need to complete the exercises in the lesson. There are two project datasets: Small Office Building_M and Steel-Framed Residence_M. The tutorial exercise steps identify the specific file to use. Extract the project datasets, and begin the tutorial.

**Extracting Datasets**

Follow this procedure to extract a dataset.

**Update project files**

2. In Windows® Explorer, browse to c:\program files\autodesk architectural desktop 2006\tutorial\architectural desktop\datasets.
   If you are using Architectural Desktop in a network environment, the tutorial files may be in a different location. Contact your network administrator or CAD manager for the location of the tutorial files.
3. Double-click the dataset - for example, Small_Office_Building_M.exe.
   The datasets are contained in self-extracting files. When you double-click a dataset, the extraction software opens.
4. If the correct path is not shown, in the Self-Extractor dialog box, click Browse and navigate to my documents\autodesk\my projects.
5. Click OK.
6. Verify that Overwrite files without prompting is cleared, and click Unzip.
   A message indicates the number of project files that were unzipped as part of this dataset.
7 Click OK in the message box, and click Close to close the extraction software.
8 Restore Autodesk Architectural Desktop.
9 On the File menu, click Project Browser.

**NOTE:** You must have a drawing open to access the Project Browser. If you do not have a drawing open, click on the Standard toolbar to create a new drawing.

10 In the Project Browser, click if necessary to locate the project folder for the tutorials. Double-click the project folder.

**NOTE:** If you have been working with non-tutorial projects, you may need to browse to my documents\autodesk\my projects.

11 Double-click the project name - for example, Small Office Building_M.
12 If you installed to a location other than the default location, when prompted to re-path the project, click Yes.
13 Click Close to close the Project Browser.
14 On the Project Navigator, click the Project tab.
15 Under Current Project, verify that Name displays the correct project - for example, Small Office Building_M.
   To change the current project, double-click another project name in the Project Browser, and repeat steps 13 through 16.
16 Keep the Project Navigator open, and begin the lesson.

**Learning VIZ Render 2006**

This tutorial incorporates the use of VIZ Render 2006, a separate visualization and rendering application that is included with Autodesk® Architectural Desktop. To learn more about VIZ Render, see the VIZ Render Help and Tutorials, accessible from the VIZ Render Help menu.

**Overview: Working in Architectural Desktop**

Autodesk® Architectural Desktop is an object-based CAD application. When you design in Architectural Desktop, you use a collection of objects that represent real-world building components, such as walls, doors, and windows. These objects are composed of lines, arcs, and circles, but also contain information that allows them to function like the real-world components that they represent, to relate intelligently to each other, and to display in a two-dimensional or three-dimensional context.

For example, instead of drawing a series of lines to represent a wall in a floor plan view, you can immediately draw a complete representation of the wall.

By simply switching the drawing view, you can display the same wall in an isometric view.
If you add a door to the wall and then move the wall, the door will automatically move with the wall.

If you view the wall with the door in the previous plan view, the change in location that you made in the isometric view is automatically updated in the plan view.

Because Architectural Desktop contains these "intelligent" objects, it supports a drawing-based building information modeling workflow. In this workflow, you use these objects to design a 3D building model that represents the building design.

To create a building model, you first create the building geometry in multiple drawings (DWGs), based on its location in the building model. The individual drawings are referenced together using enhanced AutoCAD® external reference (xref) technology to assemble the 3D building model. The 3D model not only represents the physical building, but also stores information about the building and its components. When you have developed the building model enough to begin documenting it, you can extract drawings, such as elevations and sections, from the building model and reference them onto plotting sheets.

The benefit of this object-based design approach is that views and data are easily extracted and can remain linked to the 3D building model. You can extract views, add them to plotting sheets to create a set of construction documents, and then update the sheets if a change in the building design occurs. Because Architectural Desktop is AutoCAD-based, you have the flexibility to work in a more traditional 2D drafting environment if you prefer, but it is recommended that you use the building information modeling approach to derive the most benefit from using Architectural Desktop.
At any point in your design workflow, you can use VIZ Render, a separate three-dimensional visualization application that is included with Architectural Desktop. You can export your Architectural Desktop design to VIZ Render, where you can create a variety of compelling presentations and design studies, including renderings, animated walkthroughs, and interactive panoramic renderings.

The next few topics in this overview describe some of the important concepts of working with Architectural Desktop.

**Designing with Objects**

Before you begin a project, it is helpful to understand some of the main features in Autodesk® Architectural Desktop that allow you to work with the architectural objects included in the application. The following example demonstrates how to draw a wall that includes a door.

To draw the wall, you select a wall tool from a tool palette.

**A wall tool on a tool palette**

Tools are commands that you use to draw objects. Tools take the form of icons on tabbed panels called palettes. The tool image represents the real-world object that you want to draw. Tool palettes are organized within tool palette groups, which contain tools that support a specific work task. The wall tool used in this example is from the Walls tool palette within the Design tool palette group.
The wall tools on the Walls tool palette in the Design tool palette group

Before you begin to draw the wall, the properties of the wall are displayed in another palette below the Tool palette, called the Properties palette. You can change some of these properties, such as the width or base height of the wall, before you draw the wall.

The Properties Palette

Before you specify the start point of the wall, you can use the drawing aids on the application status bar to help you control how the wall is drawn. To draw this short straight wall segment, you want to click **ORTH** to constrain your cursor to move only in a horizontal or vertical (orthogonal) direction after you specify the start point.
Next, as you move your cursor to specify the length of the wall, the value in the Length field in the Properties palette changes. When the length field reports the desired length of the wall, you can specify the wall endpoint in the drawing.

Alternatively, you can click the dynamic input option (DYN) on the application status bar to use a direct entry method to specify the endpoint of the wall. This option provides a field that you can use to enter the desired length of the wall, instead of specifying a point in the drawing. The angle of the wall is also reported in a separate field as you move the cursor. You can press TAB to toggle between the two fields.

A number of features work together to represent the completed wall in your drawing: the layer, style, and display settings that are assigned to the wall.

The wall is automatically drawn on a named layer with predefined settings such as color, linetype, and linewidth. When you draw an object, a layer key style associated with the drawing matches the object to a defined layer in a process called layer keying. The layer name and settings are determined by a layer standard that is associated with the layer key style and the drawing. The wall is drawn on layer A-Wall, a layer which conforms to the AIA (American Institute of Architects) layer standard, but you can use any of the international and professional standards that are included in Architectural Desktop. You can also create your own office layer standard.

The style of the wall determines what type of wall is being drawn. A style is a set of parameters that you apply to an object to determine its appearance or function. For walls, styles contain components, which are the materials used to construct the wall, such as brick, CMU, concrete, studs, air gaps, and insulation. They also can contain wall modifiers, which change the shape or surface of a wall component.

**Walls with different styles**

Other object styles contain different parameters. For example, a door style determines the shape (rectangular, arch, half-round, and so on) and type (number of panels and opening method) of the door. In most cases, the image of the tool that you select to draw an object represents its style.

Finally, how you view the drawing in the drawing area helps to determine how the wall looks. A display system works behind the scenes in Architectural Desktop to control how objects in your drawings are represented. Each object has a number of display representations, or different ways they can be shown, depending on the type of drawing in which you need to use them. These display representations control the look of the object geometry as appropriate for different drawing types, such as high detail plans or reflected ceiling plans. You create objects one at a time in the drawing area, but you can change how they are represented, which allows you to manage plan views in low, medium, or high detail, or create reflected ceiling plans - all from the same geometry.
Most objects are made up of individual display components within a display representation. The properties of each component, such as visibility, layer, linetype, and lineweight, can be configured in the display representation to change how the object displays in a drawing.

Display components in the Plan display representation of a wall
Different object display representations are grouped in display sets. Display sets group display representations according to the type of view the objects need to display in. For example, the Plan display set includes the Plan display representations of walls, curtain walls, doors, stairs, railings, and roofs. Display sets are then assigned to view directions in display configurations, which can be changed for the drawing area and can be attached to viewports in a sheet layout. By changing the display configuration and/or view direction in a viewport, objects in that viewport can display differently, you can "represent" the same objects multiple ways for use in different types of drawings.

A display configuration has representation sets assigned to view direction

![Display Manager](image)

The drawing is a volume (cube) with representation sets assigned to the viewing direction.

![Drawing](image)

Drawing templates provided with Architectural Desktop contain display settings that you use to easily manage the display of objects in your drawings created from these templates. They also associate particular layer standards and layer key styles to drawings. Object styles are not included in the templates, but stored and managed in one or more external drawings.

Next, you want to add a door to the example wall. You select a door tool, and select the wall. You can adjust any of the properties of the door in the Properties palette before you select the wall a second time to place the door in the wall. Simply moving the cursor to either side of the wall before you place the door flips the door swing from one face of the wall to the other.

A door placed in a wall

![Door](image)
You can edit or change the style of either the wall or door to change its appearance. Object styles are the main way to differentiate between building components. You would have, in a project, multiple styles for objects such as walls, doors, and windows. Editing any door or wall style in the current drawing will change all doors or walls of the same style. In addition to the ability to edit a style you can change object display settings for a single object (such as the wall) or for all the walls with the same style.

**Display components turned off in an individual door representation**

![Display components turned off in an individual door representation](image)

**Display components turned off in a door style**

![Display components turned off in a door style](image)

You can change the properties of the individual wall or door, such as overall dimensions, by double-clicking them and changing the properties in the Properties palette, or by selecting them and grip-editing them onscreen. When you select and move a dimension grip, dynamic dimensions are displayed, allowing you to precisely move the grip. The door also has grips that enable you to flip the door swing to the other face of the wall or reverse its direction.

**Grip-editing a wall and door**

![Grip-editing a wall and door](image)

If you move your cursor over a grip, a grip tip displays the name and function of the grip. Often the grip tip lists editing options.

**A door grip tip**

![A door grip tip](image)

Moving the wall with its location grip will also move the door. This inter-relationship between objects is what allows you to create 3D building models or drawings with a minimum of editing. You do not have individual linework requiring extensive editing; instead, you have associated objects.

In the next section, you learn how to create a building project. Within the project, you create a building model and extract information from it to create construction documentation. For more information on the concepts and features in this section, see the online *Architectural Desktop User’s Guide*.

**Completing a Project**

After you have created a conceptual study and have understood the design requirements of a building project, you have a good idea of your building design. You know the basic structure of the building, and how many floors or
divisions, such as wings or phased expansions, it has. You can also identify the major components of the building. You may have schematic drawings or drawings from a previous project that you want to use to create parts of the building design. At this point, you are ready to start a project in Autodesk® Architectural Desktop.

A project in Architectural Desktop is not just a job name or number; it stores, organizes, and manages the drawings that make up both your building model and the plotting sheets. Within the project, drawings that contain the building model geometry are referenced together, and then views of the building model are referenced onto plotting sheets.

When you create a project, you can specify the project information, including the project name, number, description, and the templates that contain the layouts, styles, and display settings for different types of drawings in your project. You can also designate project-specific tool palettes that contain tools tailored for the building in the project.

The project file structure is created when you create a project. There is no need to set up a file structure for the project in Windows Explorer. Two UI elements within Architectural Desktop, the Project Browser and the Project Navigator palette, provide access to your projects and the drawings organized within them. The Project Browser lets you create, set up, and switch between projects.

**The Project Browser**

The Project Browser provides the context in which you create, edit, and manage all of your project drawings.

**The Project Navigator palette**

The project structure contains a main project folder with a number of sub-folders to organize the different types of drawings that the project will contain. Drawings are classified within the project as constructs, elements, views, and sheets.

Two types of drawings, constructs and elements, contain the geometry that is referenced together to create the building model. Both drawing types are DWG files; there is no difference in file type or format. The only difference between them is the way that they are used and how they are referenced to create the building model.
Constructs are the main building blocks of the model. They define unique portions of the building and are assigned to a location (level and division) within the building. For example, assume an existing commercial building with multiple floors and one division (the existing building or main division). The first floor of the building could consist of an exterior shell construct, a first-floor construct with lighting, and a first-floor interior partitions construct. Each of these constructs would be assigned to the first level and the main division of the project. The exterior shell construct, drawn to the full height of the building, would be assigned to all levels of the project, making it span the height of the building. This type of construct is called a spanning construct. The construct’s level and division assignments define its exact location in the building model.

**A lighting construct assigned to its location in the building**

<table>
<thead>
<tr>
<th>Level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1F</td>
<td>Exterior Shell</td>
</tr>
<tr>
<td>2F</td>
<td>First Floor Lighting</td>
</tr>
<tr>
<td>3F</td>
<td>First Floor Interior Partitions</td>
</tr>
</tbody>
</table>

**A spanning construct drawn to span several floors and assigned to the floors (levels)**

Elements are collections of geometry that can be referenced repeatedly within multiple constructs. You could apply a typical service core element that includes restrooms to constructs assigned to multiple floors. You would draft the core once as an element, but it would report as separate items (doors, walls, and so on), because the items are referenced to separate constructs. If you tag each service core door, the doors would report as individual items in a schedule.
When you set up the basic levels and divisions of a building model, you create a matrix of locations where you can assign the building geometry that will create your building model. By default, a project has one level (that has an elevation of 0 and represents the ground floor) and one division.

When you have developed the building model enough to begin documenting it, you reference views of the building model onto plotting sheets. A view drawing references a number of constructs according to their location in the building to present a specific view of the building model. To create a view drawing, you decide what part of the building model you wish to look at and the type of view to generate. You could, for example, create a first-floor reflected ceiling plan or a second-floor framing plan. You could also create a composite view of all floors in the building.

You can create three different types of views within projects: general views, detail views, and section/elevation views. General views reference constructs to create specific views of the building model. Detail and section/elevation views contain one or more model space views that display a defined portion of the drawing. A model space view is a portion of the view drawing that may be displayed in its own viewport on a layout tab of a drawing. You can automatically create Detail and Section/Elevation views with callouts. The resulting named model space views can subsequently be annotated and placed on sheets.

**A model space view for an automatically created house elevation, placed on a sheet**

Sheet drawings are the DWG files that you plot or electronically publish to produce construction documents. Sheet drawings contain sheets, which are paper space layouts that provide the layout of the sheet. You reference model space views from view drawings onto sheets to create sheet views. Any changes that you make to the model can be updated in the sheets because the building model drawings are referenced into the views on the sheets.

You can add annotation like tags, dimensions, and schedule tables to a sheet, or you can add it in a view that you reference onto a sheet. Whether to create the annotation in a view or on a sheet is a decision you make based on your workflow and individual needs.

Each project contains a single sheet set, which is a named and ordered collection of all the sheets in the project. The project sheet set represents the project documentation. You can plot the sheets or electronically publish the sheet set to a DWF (Design Web Format) file that can be viewed by anyone using Autodesk® DWF Viewer or Autodesk® DWF Composer.

To establish, maintain and synchronize standards across all the different types of drawings in an Architectural Desktop project, you can set up project standards. The Project Standards feature lets you set standard styles, display settings, and AutoCAD standards that you want to use in all your project drawings. Standard styles and display settings are specified in one or more standards drawings that you associate with the project. You can then synchronize your project drawings with these standards throughout the project lifecycle, either automatically, or on demand.

### Integrating VIZ Render in Your Project Workflow

VIZ Render is a separate three-dimensional visualization application that is installed with Autodesk® Architectural Desktop. You can export your Architectural Desktop designs to VIZ Render, where you can create a variety of compelling presentations and design studies, including renderings, animated walkthroughs, and interactive panoramic renderings. These studies are separate from your project drawings; they are not part of the current project.

When your design is at a point where you want to use VIZ Render to study or present it, you use the following workflow:

First, you export the geometry and materials that comprise your Architectural Desktop design to VIZ Render using a file linking command in Architectural Desktop.
After you click the link, VIZ Render is opened automatically, and the geometry and materials that comprise your current Architectural Desktop model are displayed in VIZ Render in a DRF file.

A live data link between the current Architectural Desktop drawing and the VIZ Render DRF is established. This link will load any changes in the geometry or material of the Architectural Desktop model into VIZ Render for as long as you retain the file link.

Next, depending on the type of visualization you want to create with VIZ Render, you can make changes and additions to the design in VIZ Render. Although you cannot model in VIZ Render, you can rearrange objects, modify their materials, and add lighting, cameras, and additional objects (like the cars and trees in the renderings below) to create a realistic environment for your design.
After you create an image or animation in VIZ Render, you may find that you need to make a change to the design geometry or material in Architectural Desktop. You can go back to Architectural Desktop, make the change, and use the live file link to load the changes in VIZ Render.

To learn more about VIZ Render, see the VIZ Render Help and Tutorials, accessible from the VIZ Render Help menu.

Understanding the User Interface

Autodesk® Architectural Desktop includes two distinct user interfaces: the workspace and the VIZ Render user interface. The workspace is displayed when you start Architectural Desktop. The workspace and its components support you through your project workflow, allowing you to move seamlessly from creating a project and designing a building model to producing construction documents.

The Autodesk Architectural Desktop workspace
VIZ Render, the separate 3D visualization application that is included with Architectural Desktop, has its own user interface that you can use to produce photo-realistic images and animations of your building designs. The VIZ Render user interface is displayed when you export an Architectural Desktop design to VIZ Render, or when you start VIZ Render from the VIZ Render icon on your desktop.

**The VIZ Render user interface**

The topics in this section describe the workspace and its components. To learn about the VIZ Render user interface, see the VIZ Render Help and Tutorials, accessible from the VIZ Render Help menu.

**The Workspace**

Before you begin the tutorial, it is helpful to understand the workspace and some of its main components. Use the illustration below to familiarize yourself with the workspace and its components, and then review the following topics.
The Autodesk Architectural Desktop workspace

The title bar is located at the top of your drawing window. The product name, product version, and current drawing name are displayed in the title bar. Standard Microsoft® Windows buttons allow you to minimize and resize the workspace, as well as close Autodesk® Architectural Desktop.

Menu Bar

The menu bar contains six default pulldown menus that are organized according to your workflow: File, Edit, View, Insert, Format, Window, and Help.

Many of the workspace components are accessed from these menus. Where applicable, the menus show alternate ways of accessing a command, such as a toolbar button or a shortcut key.

Additional pulldown menus

You can load and use four additional pulldown menus: Design, Documentation, CAD Manager, and 3D Solids.

The Design and Documentation menus are similar to those included in releases prior to Autodesk® Architectural Desktop 2004, in that they include design and documentation object commands. Use these menus as an alternative to accessing object commands from tools.

The CAD Manager menu provides access to advanced features like the VBA Editor, the LISP Editor, Project Standards, the Keynote Editor, and Tool Catalog Generator.

The 3D Solids menu provides access to the AutoCAD 3D Solids objects and commands. In Architectural Desktop, 3D solids can be converted to mass elements with material assignments that can be used in production drafting. The 3D Solids menu helps AutoCAD users make the most of their 3D drafting skills.
To load the additional menus, on the Window menu, click Pulldowns, and click the menu you want to load. After you load these menus, you can display the equivalent Design, Documentation, CAD Manager, and Solids toolbars.

**Toolbars**

Toolbars, located directly under the menu bar, contain groups of commands that you access frequently in a drawing session. Objects are not accessed from the toolbars, as they are primarily accessed from tool palettes.

Four toolbars are displayed by default: Standard, Navigation, Layer Properties, and Shapes. Many of the user interface components described in this section are located on the Navigation toolbar.

**Layer Properties toolbar: layer commands, layer list, and Layer Manager command**

**Navigation toolbar: utility, zoom, view, UCS, and shading commands**

**Shapes toolbar: 2D object commands, such as lines, arcs, polylines, splines**

**Standard toolbar: drawing, copy, paste, undo, and regenerate model commands**

To display additional toolbars, right-click in the toolbar area (not on a toolbar), and click ADT. A menu lists the toolbars that you can click to display. If you load the 3D Solids, CAD Manager, Design, and Documentation pulldown menus, you can display the equivalent toolbars.

**Drawing Window and Layout Tabs**

The drawing window is where you design and document your building models. The drawing window contains layouts, that you can switch between by clicking the layout tabs at the bottom of the drawing window.

**Context Menus**

A context menu contains commands that are relevant to an object that is currently selected, providing you a convenient way to edit the objects that you draw. To display a context menu, select an object, and right-click.
A general context menu is also available when you right-click in the drawing area without selecting an object. This menu contains all modify tools, viewing commands, and the Properties command.

**Drawing Window Status Bar**

The drawing window status bar is located under the drawing window. It reports the following information about the current project and drawing:

- the name of the current project
- the type (construct, element, view, or sheet) and name of the current drawing
- the active scale for the current drawing or viewport
- the display configuration of the current viewport or model space view

Options at the far right of the drawing window status bar provide access to the Surface Hatch Toggle, Layer Key overrides, the Isolate Objects command that hides and displays objects that you select, and access to AEC Project Standards. To display and clear these options from the drawing window status bar, click ‹›, and click the options that you want to display or clear.

To display and hide the drawing window status bar, click ‹› on the application status bar at the bottom of your screen.

**Open Drawing Menu**

To display the Open Drawing menu, click ‹› on the drawing window status bar. A menu displays a number of drawing setup, plotting, and publishing commands. You can use the Drawing Setup command to change settings of your current drawing, such as the active scale, layer standard, and layer key style. Also included is the Link to VIZ Render command that you use to export building model geometry and materials from Architectural Desktop to VIZ Render.
**Command Palette**

The command palette is located under the drawing window. If you prefer, you can enter all Architectural Desktop commands directly on the command line, including those used by the tools.

To display a list of Architectural Desktop commands:

- On the command palette, enter `arx`.
- Enter `c`.

**Application Status Bar**

The application status bar is located under the command palette and contains a number of drawing aids.

You can also access the Communication Center, an in-product notification system that keeps you up to date on service pack availability and provides information for Autodesk® Subscription Program members. When new updates are available, the Communication Center icon displays with a yellow exclamation mark.

**The Project Browser and Project Navigator Palette**

The Project Browser and Project Navigator palette are the two workspace components that you use to create and manage Architectural Desktop projects. The Project Browser provides you high-level management of your projects: you use it to create, copy, and switch between projects. After you create or select a project and close the Project Browser, the Project Navigator palette is displayed automatically. You use it to create, edit, and manage the drawings within the project.

**The Project Browser**

To display the Project Browser:

- On the File menu, click Project Browser.
- On the Navigation toolbar, click 
- To configure the Project Browser to display when you start Architectural Desktop, click Format ➤ Options. Click the AEC Project Defaults tab, and select Show Project Browser at startup.

In the Project Browser, you can create projects, switch from one project to another, and copy projects. You can also:

- define or change the project settings, including the templates, standards, and tool palettes.
- specify the detail component and keynote databases that you want project members to use to create details.
- electronically transmit and archive projects.

The current project is displayed on the top left side of the Project Browser. You can associate a graphic to display next to the project name. Below the current project, available projects are listed under the project folder location. A Windows® Explorer-like tree allows you to navigate the project directory. The right pane of the Project Browser includes an embedded Internet Explorer that allows you to link to a web page on an Internet or intranet site. You can use the linked web page as a bulletin board for communicating project information, such as photographs, meeting times, and issues, to the project team.
After you create a new project or set a project current and close the Project Browser, the Project Navigator palette is displayed.

**Project Navigator Palette**

**To display the Project Navigator palette:**

- Close the Project Browser.
- On the Window menu, click Project Navigator Palette.
- On the Navigation toolbar, click ...
- Press CTRL + 5.

The Project Navigator palette is the context in which you create, edit, and display all of your project drawings, including elements, constructs, views, and sheets. The Project Navigator contains four fixed tabs that correspond to the main phases of a building project:

- The Project tab contains the project information, including the levels and divisions in the building model, a Content Browser icon that will open a project-specific library of tools, and a link to configure project standards.
- The Constructs tab manages the construct and element drawings that create the building model.
- The Views tab manages the drawings that contain views of the model that you reference from constructs.
- The Sheets tab organizes all the plotting sheets that you create from referenced views into a single project sheet set.
The Constructs, Views, and Sheets tabs organize the project drawings in a tree view, the Drawing Explorer. You can organize the drawings in categories within the tabs of the Drawing Explorer and drag the drawings between the categories. You can also drag elements, constructs, views, and sheets into the drawing area, and drag objects from the drawing area into an element or construct on the Constructs tab in the Project Navigator.

You can drag drawings from previous projects, AutoCAD drawings, and Autodesk® Building Systems drawings into the Project Navigator from Windows Explorer to be added to the project as elements, constructs, views, or sheets. This allows project team members or consultants using AutoCAD or AutoCAD LT® to add their drawings to the project.

The references that create the project drawings, typically of an element to a construct, a construct to a view, and a view to a sheet, enhance drawing coordination. An update to a construct in a project, such as a floor plan, is automatically passed along to a view of an annotated floor plan and a sheet containing the scaled view. Notifications of changes are sent to project team members as the drawings change, so team members can update any of their drawings that reference the update drawings.

Tools and Tool Palettes

To display the tool palettes set:

- On the Window menu, click Tool Palettes.
- On the Navigation tool bar, click .
- Press CTRL + 3.

One of the first things that you see in the Architectural Desktop workspace is that tools are organized on individual tool palettes on a larger tool palette, the tool palettes set. Tools represent the individual objects you can add to a drawing. The tool image is a preview of the tool style. When you add an object with a specific tool, the object is created with the settings defined in the tool properties.
The Design tool palette

Three default tool palette groups - Design, Document, and Detailing - provide instant access to a complete inventory of Architectural Desktop tools. The three tool palette groups correspond to stages in the architectural design process and contain palettes that feature relevant tools. For example, the Design palette group contains Design, Massing, Walls, Doors, and Windows palettes. You might use the Design palette, which features objects with standard styles only, in your early design stage, and then use tools from the Walls, Doors, and Windows palettes to convert the objects to specific styles later in the project. To display all the tool palettes from the available tool palette groups, click the title bar of the tool palettes set, right-click, and click All palettes.

All Design, Document, and Detailing palettes

You can add tool palettes to tool palette groups from a tool catalog in the Content Browser, a utility where you can store, share, and exchange tool and tool palettes. You can create custom tool palettes that address your specific design needs, like a palette that stores commonly used curtain wall, stair, and window tools. Tools can be organized on palettes with separators and text to structure large palettes.
New projects contain project-specific tool palette groups that have the same name as the project in which they are created. You can create project-specific tools and store them in such a palette group. If you open a project that was created in an earlier release of Architectural Desktop, no project tool palette group is displayed.

You can create projects according to building type, such as residential, commercial, or educational, and then use these projects as templates to create other projects. Creating projects from these template projects lets you create projects that have custom tools, palettes, and content ready for use at the inception of a new project.

**The Properties Palette**

**To display the Properties palette:**

- Select a tool.
- On the Window menu, click Properties Palette.
- On the Navigation toolbar, click .
- Select an object, right-click, and click Properties.
- Press CTRL + 1.

The Properties palette provides a single location where you can enter and change the properties of both Architectural Desktop and AutoCAD objects. You can enter information about the style, dimensions, location, and other characteristics of an Architectural Desktop object.
Content Browser

To display the Content Browser:

- On the Window menu, click Content Browser.
- On the Navigation toolbar, click .
- On the bottom of the Project Navigator Palette, click (to access a project-specific tool library).
- Press CTRL + 4.

The Content Browser lets you store, share, and exchange Architectural Desktop content, tools, and tool palettes. The Content Browser runs independently of Architectural Desktop, allowing you to exchange tools and tool palettes with other Autodesk applications, such as VIZ Render. Architectural Desktop tools and content are shared in the Content Browser using tool catalogs and websites. Content that was only accessible from the DesignCenter in previous releases, is now available as tools stored in the Content Browser.

A tool catalog can contain tools, tool palettes, and tool packages (collections of tools). Tool catalogs are placed in catalog libraries. A Content Browser library can be set up on a shared network volume to be accessed by all users in a specific project. The CAD manager or project owner can point the project to that Content Browser library to have quick access to standard tools.

The Content Browser window is usually divided into two panes (web pages displayed in the Content Browser occupy the entire window). Tool catalogs and their contents are displayed in the right pane. When you start the Content Browser, your personal catalog library, named <user_name>’s Catalog Library, displays in the right pane. The left pane is used for navigation, searching for tools, sorting catalogs, and filtering catalog display.
The Content Browser

To display the DesignCenter:

- On the Insert menu, click DesignCenter.
- On the Navigation toolbar, click .
- Press CTRL + 2.

The DesignCenter™ provides another location where you can browse and share content, such as blocks and symbols, between drawings. You can access content from your open drawings, drawings on your system, or drawings on a network. A library of AEC (architectural, engineering, and construction) content included in Architectural Desktop is accessible through the DesignCenter. Four tabs in the DesignCenter, (Folders, Open Drawings, AEC Content, and DC Online), offer access to content in the different locations.

You can also access content on web pages with DesignCenter Online. DesignCenter Online provides access to catalogs of manufacturer's content that you can “i-drop®,” or select and drop into your drawings.

DesignCenter Online
You can drag content from the DesignCenter directly into a drawing or onto a tool palette to create a tool, but you cannot drag tools directly from the Content Browser into the DesignCenter. Instead, drag tools that you create from DesignCenter content from the tool palette into a catalog in the Content Browser.

**Detail Component Manager**

To display the Detail Component Manager:

- On the Insert menu, click Detail Component Manager.
- On the Navigation toolbar, click 
- Right-click a detail tool on a tool palette, and click Detail Component Manager.

The Detail Component Manager provides access to industry standard detail components that you can insert in your detail drawings. Detail components are 2D linework representations of specific building materials and products that are stored in Microsoft® Access databases (MBD files). If the detail components that you want to use are not accessible as tools on tool palettes, you can use the Detail Component Manager to select a component database and search for specific components. Although you can insert the components directly into a drawing, you may want to drag any components that you will use repeatedly from the Detail Component Manager onto a tool palette to create detail tools.

When you define or change project settings, you can specify the detail component database(s) that you want to use to create project details, ensuring that all project team members use components from the same databases. Two detail component databases are included with Architectural Desktop: one US-specific database that organizes components to the CSI MasterFormat standard and one UK-specific database that organizes components to the NBS standard. You can also specify a custom database.

When you insert a detail component, you can place multiple components, such as stacked bricks. You can insert detail components in alternate views, such as section or elevation. Detail components are linked to a keynote that you can use to automatically identify the component when you add annotation to the detail.

**Arranging Your Workspace**

You can arrange the toolbars and dockable windows, such as the palettes and the DesignCenter, in your workspace to suit your design task or personal preference.

You can drag toolbars to position them in the workspace. You can drag toolbars to the sides and bottom of the drawing window and dock them. After you arrange toolbars in your workspace, you can lock your toolbars into position. To
lock and unlock the position of the toolbars in the workspace, you can click  or  on the application status bar at the bottom of your screen. On the menu that is displayed, you can lock or unlock all docked toolbars, all floating toolbars, or all toolbars.

Windows, such as the Properties palette, the Tool palette, the Project Navigator palette, and the DesignCenter, can also be docked, but only on the left and right sides of the drawing window.

The Tool Palette Set docked on one side of the workspace

To enable palette docking, right-click on the tool palette title bar, and click Allow Docking. Then, drag the palette to either side of the window. You can lock and unlock palettes with the same option that you use to lock and unlock toolbars. To control the size and listing of tools on palettes, right-click on a palette, and select View Options. You can size the tools as appropriate for your screen resolution and workspace arrangement.

After you arrange your workspace, you can save it and then create additional workspace arrangements. You could customize workspaces for particular design tasks, and switch between workspaces. The Workspaces toolbar contains commands that allow you to save and switch between workspaces. For more information, see Use Workspaces in the online AutoCAD 2006 User’s Guide.
Getting Started with Projects

The Drawing Management feature of Autodesk® Architectural Desktop software provides you with tools for creating large building projects that are distributed among many drawing files. Drawing Management formalizes and automates the organization and management of external reference files, letting you work with the logical pieces of a building, as opposed to managing the file system.

In this part of the tutorial, you are introduced to the key concepts of Drawing Management as you begin the design development phase of a sample commercial building project.
Understanding the Tutorial Project

Autodesk Architectural Desktop and the tutorial dataset feature powerful tools to assist you in the creation of projects and the design of a five-story office building. The office building consists of approximately 2300 square meters per floor, a three-story atrium area with an angled staircase, a centralized bank of elevators, and two emergency exit stairwells. The interior atrium space also includes a typical central core of conference rooms, bathrooms, and storage rooms, in addition to open space intended for future cubicle and office layouts. The tutorial covers new features that allow you to create a project template. The project template has project standard object styles for use in all project drawings and a project palette with tools specific to the building type. The goal of the tutorial is to have you create a project template that is reusable for future work on buildings of the same type.

If you have not done so already, you should install the small office building dataset. The first two lessons in this part of the tutorial involve creation of a project template for an office, an exploration of drafting technique in that you refine a sketch to produce generic objects, then replace the generic objects with styles representing the finished building components. The third and last lesson of this part shows how to version styles, update the project standard styles and then populate the project drawings with the latest version of a style from a single source - the project standards. You also see how a new or revised object style can be uploaded to the project standards from a project drawing, so as to make it available for project tools and the validation of all project drawings.

Lesson 1: Setting up the Small Office Building Sample Project

As you begin the design development phase of a project, you familiarize yourself with the requirements of the project as outlined in the design program and conceptual drawings. Often you can begin to identify design objects that will be repeated throughout the building model, such as specific types of walls, doors, and windows. In Architectural Desktop, you can create tools that represent your most frequently-used design objects, allowing you to add objects such as walls, doors, and windows to your drawings quickly and easily.

This lesson introduces you to the key concepts essential to working with projects that are organized and managed in a project environment. This introduction focuses on the fundamental information you need to be successful as you begin your work with projects. For in-depth coverage of project-related topics, use the cross-references provided throughout the lesson. Finally, you create a new project, which forms the basis for future work. You create a project template, with project standards styles and tools. This is a one-time task that lets you see how you can create templates for the building types you specialize in. When you have finished the project for use as a template, you can then begin any similar project with all the required standards configured and project-specific tools readily at hand in project-specific palettes.

Exercise 1: Exploring Project Drawings

This exercise introduces you to the terms and concepts that are essential to working in a project environment by exploring the contents and structure of a sample project. This introduction focuses on the fundamental information you need to be successful as you begin your work with projects. For in-depth coverage of project-related topics, use the cross-references provided throughout the exercise.

As you explore the sample project, you work with two key components of the project environment: the Project Browser and the Project Navigator. In the Project Browser, you create a new project, or select an existing project in which to work. In the Project Navigator, you perform all project-specific tasks, such as creating, organizing, and accessing project drawings. In this exercise, you use the Project Browser to open the Small Office Building Sample Project. You use the Project Navigator to explore the contents and organization of this project.

The Project Navigator is a palette that remains open during your project session. The Project Navigator gives you access to the various drawings that make up your building model, and it allows you to control the way in which your building model is organized into a project.

Conceptually, a project is composed of two parts: the building model and the reports that are generated from the building model. The building model is made up of two types of drawing files: constructs and elements. Reports are made up of views and plot sheets, which are also drawing files. This exercise introduces you to these key project components, as you explore the structure that allows you to effectively organize the building and documentation data that make up your project.

**NOTE:** If you are not using the metric version of the software, but you want to work in metric units in this tutorial, open a metric template before continuing with this exercise.
Open the Project Browser

1 On the File menu, click Project Browser or, on the Navigation toolbar, click .

At the top left of the Project Browser is the project header. When you select the project you want to work with, the project header displays the project name, project number, optional bitmap image, and optional project description. You enter this information when you create a new project or edit an existing one. Unless you have added and selected another project, the Project Browser shows New 2006 Project as your current project. New 2006 Project is a default project you can use.

Below the project header is the project navigation toolbar, which helps you navigate the operating system and control the order of the project listing.

Below the project navigation toolbar is the project selector. The project selector displays the projects you have created in Architectural Desktop, and allows you to browse to locations where projects are stored. You also use the project selector to select the project environment in which to work.

TIP: Use the drop-down list for the project folder location to browse to the installed projects. The Small Office Building project, by default, is installed to \my documents\autodesk\my projects.

If you are using Architectural Desktop in a network environment, the tutorial files may have been installed in a different location. Contact your network administrator or CAD manager for the location of the tutorial files.

2 Select the project environment in which to work
In the Project Browser, right-click Small Office Building_M, and click Set Project Current. You can also double-click a project name to make it current.

3 If prompted to re-path the project, click Yes.
When you move a project, you need to re-path the project to update the external reference paths.

Small Office Building_M is set as the current project environment. The current project is displayed in bold text in the project selector. The project header displays the project name, project number, project image, and project description that were entered when the project was created.

The right window of the Project Browser is the project bulletin board. It is an HTML page that is linked to the project. When you create a project, you can link it to an Internet home page, such as your company’s home page or a project Web site. The navigation toolbar below the bulletin board includes icons for Back, Forward, Stop, Refresh, and Project Home. A project bulletin board is a way to communicate with project members about project meetings, issues with the drawings, share site photographs or connect to other documentation such as animations and DWF files.

4 Click Close to close the Project Browser.
The Project Navigator is displayed. If the Project Navigator is not displayed, click Project Navigator Palette on the Window menu.

5 View project information in the Project Navigator
Verify that the Project Navigator is displayed.
The Project Navigator has four tabs on which you can enter project data. The tabs correspond to the main phases of project creation: defining general project information, creating building data, and creating building documentation (views and sheets). Next, you view the Project tab.

6 Verify that the Project tab is displayed.

**Define building divisions and levels on the Projects tab**

On the Project tab, you can use the edit icon and then enter information that pertains to your whole project, such as the levels and divisions that make up your building model. Levels are the floors in your building model; divisions are locations such as the main building or the west wing. Together, levels and divisions create a framework that allows you to label unique portions of your building model. For example, you could have an arrangement of offices in your building named O1 Offices and assigned to First Floor - West Wing.

By default, a new project consists of one level and one division. You can add and modify levels and divisions throughout the life of the project.

The sample project in this tutorial consists of six levels (five floors and a roof level), and a single division (main building). Next, you preview drawings, and review level and division assignments for constructs.

7 Explore constructs and construct categories
Click the Constructs tab.
Constructs are the main building blocks of a building model.
8 Under the Constructs folder, locate the Architectural folder and the Structural folder at the next level in the hierarchy.

The Architectural folder and the Structural folder represent construct categories. In this sample project, the constructs are categorized by discipline: Architectural and Structural. Each discipline category contains subcategories, such as Building Outline and Partitions. Categories help you organize the various parts of your building project. As you explore the sample project in this exercise, notice the categories that have been established. In the next lesson, you create a new project and establish a set of categories to be used throughout the project.

9 Locate the Partitions folder.

Like the other folders at this level of the sample project, the Partitions folder contains individual construct drawings.

10 Click 02 Floor Partitions.

11 If Detail is displayed below the Constructs tree, click to display a preview of the 02 Floor Partitions construct in the Preview window.

A construct is a drawing that represents a unique portion of the building model, and is assigned to a specific level and division within the project.

12 Right-click 02 Floor Partitions, and click Properties.
13 Under Assignments, notice that the 02 Floor Partitions construct is assigned to Division 1, Level 2. Most projects require that each level and division be represented by multiple constructs. For example, the second floor of the sample project is made up of the 02 Floor Partitions construct, the Typical Floor Shell construct, and the 02 Floor Slab construct. Spanning constructs, such as Typical Floor Shell, drawn in one drawing to span multiple levels and assigned to multiple levels.

Any number of constructs may be assigned to the same portion of the building. The more complex your building project, the more beneficial proper categorization becomes in organizing and managing the building model data. By describing each portion of your building model as a unique construct, you can easily create specific views of your building project. Later in this exercise, you explore views that have been created using the constructs on the Constructs tab. When you create a view, you are asked to identify the location (level/division), and are presented with a list of potential external references for the view.

14 Click Cancel.

15 Preview two or three constructs from different categories, not including the Elements folder. Elements are a separate type of project component and are explored next.

16 Explore elements
On the Constructs tab, scroll to the Elements folder.

**The Elements folder on the Constructs tab**

![Constructs folder screenshot]

17 Click Typical Core to display a preview of this element.

Elements are the smallest building blocks within a project. Usually, an element is a repeating design object in the building model that is referenced into multiple constructs. In the sample project, the Typical Core element was drawn once and referenced into four constructs: 01 Floor Partitions, 02 Floor Partitions, 03 Floor Partitions, and 04 Floor Partitions.

An element is a repeating component in the building model, so it has no level or division assignment. To place an element on a specific floor and division, you need to reference the element into a construct. A construct has a level and division assignment.

18 Explore views and view categories

After the structure of the project is defined and constructs are created and assigned to levels and divisions, you can begin creating views. A view references one or more constructs to present a specific view of the building project. To create a view, you decide what portion of the building you wish to see, and which type of view you wish to generate. You could, for example, create a second-floor plan or an exterior elevation view. You could also create a composite 3D view of the building model.

Click the Views tab.
Create, edit, and organize specific views of the building model on the Views tab

Notice that the views for the sample project have been categorized based on architectural features and the interior and exterior views of the building model. There is also a Mechanical category that contains a completed consultant drawing. Categories help you organize the various parts of your building model and the reports that are generated from it.

19 Under Plans, click 01 Floor Plan.

20 Click to display a preview of the 01 Floor Plan view.

Views reference the appropriate constructs according to their location within the building. When you create a view of the building model, you select the level or levels for which you want to create the view, and all constructs assigned to that level are referenced into the view drawing automatically. The 01 Floor Plan view was created by selecting level 01, which automatically referenced all constructs that were assigned to level 01: Typical Building Outline, 01 Floor Partitions, Typical Floor Shell, Column Grid, and 01 Floor Slab.

When you create a view, you can exclude individual constructs that are assigned to the portion of the building model for which you are generating the view. For example, in 01 Floor Plan, the building outline construct assigned to level 01, Typical Building Outline, was excluded. You can also include additional constructs as needed, such as a structural framing construct assigned to another floor, which you want to see in the 01 floor plan.

You can add annotation to a model space view, much like you added annotation in model space in previous releases of Architectural Desktop. As shown next, you can also add annotation to plot sheets, much like you added annotation in paper space in previous releases of the software.

21 Explore sheets

Plot sheets reference model space views, and can be used to add annotation data to the project. In the sample project, the plot sheets represent a set of construction documents for your building project.

On the Sheets tab of the Project Navigator, you can create and manage the plotting sheets for a project. You work with the project sheet set, and can perform tasks that affect the entire sheet set, such as creating a sheet list or publishing the sheet set. You can also create sheet subsets; open sheet views; assign numbers to sheet views; and add, modify, or delete sheets in the project.

Click the Sheets tab.
Create, edit, and organize plot sheets on the Sheets tab

Notice that the Sheet Set View displays the hierarchy of sheets and sheet subsets for the sample project.

22 Under Architectural\Plans, double-click A101 Ground Floor Plan to open the sheet in the drawing area.

23 Examine the view displayed in the sheet.

This sheet contains an external reference to the Ground Floor Plan view. After the sheet was added to the project, the Ground Floor Plan view was dragged onto a paper space layout in the A101 Ground Floor Plan sheet. When you drag a model space view from the Project Navigator onto a paper space layout in a sheet, the following actions take place:

- The view drawing is externally referenced into the plot sheet drawing’s model space.
- A viewport is created on the current layout, scaled according to the settings held in the model space view’s properties.

24 Examine the overall building dimensions.

The dimensions in this drawing were added to the view. Optionally, you could add annotation, such as schedule tags and tables, dimensions, and title marks to the plot sheet. Whether to create annotation on plot sheets or in views is a decision you should make based on your workflow and individual needs. For example, using callout tools creates a workflow in which annotation, tags, and titles are placed in views.

25 On the File menu, click Close to close the sheet, and click No when prompted to save the drawing.

26 In the Project Navigator title bar, click X to close the Project Navigator.

In this exercise, you explored the Small Office Building Sample Project, while being introduced to the terms and concepts that are essential to working within a project environment. Using the Project Browser, you accessed the Small Office Building Sample Project, and selected it as the project environment in which to work. In the Project Navigator, you viewed the organization and contents of the default project categories: Constructs, Elements, Views, and Sheets. The relationships among these project components can be summarized as follows: Within a project, elements are referenced into constructs, constructs are referenced into views, and views are referenced into sheets.

Exercise 2: Creating a Set of Project Tools

In Autodesk® Architectural Desktop, you can use tools to add architectural objects, annotation, and documentation to your drawings. The tools are organized on tool palettes, which are groups of tools that support particular tasks or processes. For example, the Walls tool palette contains tools for several commonly-used interior and exterior wall styles, while the Documentation tool palette contains tools for working with schedules and areas. To use a tool, simply click the tool on the palette and begin drawing in the drawing area.

When you install the software, several tool palettes are provided. You can begin using these default tools right away. You can modify the tools on these palettes, or create new tools and palettes to meet your project-specific needs.
You can assemble your tools and tool palettes into catalogs. Your library of catalogs is stored in the Content Browser. You use the Content Browser to store and retrieve your complete inventory of stock and custom tools, content, and tool palettes.

This exercise shows how to open a tool catalog in the Content Browser, and retrieve a tool palette that contains architectural object tools. In later exercises, you use tools to add objects such as slabs, walls, and doors to your drawings.

The objects you add with these tools behave like their real-world counterparts. For example, a wall tool has all of the parameters of real wall components built into it. When you add a wall to your drawing, you can use the default parameters or modify them.

Like all architectural objects in Architectural Desktop, a wall is a “smart” object that adheres to a set of built-in rules that control its behavior under certain circumstances. For example, if you add a door to a wall, the door cuts an opening in the wall, and the endcaps of the wall adjust to accommodate the dimensions of the door. If you move the door along the wall, the opening moves with the door. If you remove the door, the opening in the wall is removed as well. In this way, architectural objects interact with other building model objects and update dynamically to reflect design changes.

In addition to rule-based behavior and dynamic updates, architectural objects have another advantage over traditional drafting with lines, arcs, and circles: display representations. Architectural objects can be represented two-dimensionally or three-dimensionally, all with a single object. Therefore, you can add the object once, and then use different built-in representations of the object to produce different views of the object, such as a plan or model view. When you modify an object, the change is reflected in all views.

Tools make it easy to add and modify objects in Architectural Desktop. Using tools effectively and collaboratively in a project environment can increase productivity and reduce drawing errors.

**Add a tool palette for the sample project**

1. If you have not already launched Architectural Desktop, double-click the Autodesk Architectural Desktop 2006 icon on your desktop.

**NOTE:** If you are not using the metric version of the software, but you want to work in metric units in this tutorial, open a metric template before continuing with this exercise.

2. Verify that the tool palettes set is displayed.

   To display the tool palettes set, click Window ➤ Tool Palettes.

3. Open the Content Browser by clicking on the Navigation toolbar.

   The Content Browser holds your library of tool and content catalogs. You can store and retrieve your own customized tools, content, and tool palettes, and you can share tools and palettes with other members of your design team through your intranet or the Internet.

4. Click Sample Palette Category - Metric.

5. In the left pane of the Content Browser, click Document.

6. Click next to Scheduling palette, and drag it onto the tool palettes set.
When you move the cursor over the i-drop® icon, the cursor changes to a dropper image, indicating that you are in insertion mode. Use the i-drop insertion method to drag and drop content from catalogs into your current drawing. The tools from the Content Browser are designed for general use. Tools can be customized for a project and you will do this in tutorial exercises.

The Sample Palette - Scheduling is added to your existing tool palettes. You can use the Content Browser to access additional content and tools that are not displayed in the default tool palettes. It is also an option to share palettes. Managing shared tool palettes ensures that all project team members use the most current tools created or modified for a particular project or function. When a tool palette is shared from a catalog, the Refresh icon () is displayed in the lower right corner of the palette to allow updates from the source palette.

7 Working with floating tool palettes

You can work with tool palettes in two ways: floating or docked. Floating tool palettes can be moved within the drawing area, resized, and hidden. Docked tool palettes are placed in a specific location in the drawing area, and they remain in that location unless you turn off the docking option and move the tool palettes. If your tool palettes are docked and you want to switch to floating tool palettes to complete this exercise, right-click the top edge of the tool palettes, and then click Allow Docking.

Resize the tool palettes set by dragging the bottom edge of the tool palettes set down until all tabs are visible.

8 Right-click on the tool palette bar and select Design.

9 Click the Doors tab to view the contents of this tool palette.

Each tool palette contains a group of related tools. You can modify the tools on a palette, or create new tools and palettes.

10 Click the stacked tabs on the tool palettes set to display the list of available palettes, and click Windows.

The Windows tool palette is displayed. When there are more tool palettes than can be displayed within the current height of the tool palettes set, the tabs are “stacked” at the bottom. The list of tool palettes shows all available palettes. The tab names that are displayed below the line on the list are the ones that are hidden.

11 Click Auto-hide () on the title bar of the tool palettes set, and move the cursor off the tool palettes set.

When you select Auto-hide on any palette title bar, only the palette title bar is displayed when the cursor moves off the palette. You may prefer to minimize palettes to their title bars when working in the drawing area. If you click the Auto-hide button again, the full palette is displayed when the cursor moves off the palette.

**TIP:** You can rearrange the order of the tool palettes. To move a tool palette, right-click its tab, and click Move Up or Move Down.

12 Right-click on the tool palette bar and select the project palette group.

In this exercise, you added the Scheduling palette to the collection of tools available on the Tool palettes. Using the Content Browser, you opened the Sample Palette Catalog, and dragged the Scheduling palette onto the Tool palettes.

In this lesson, you reviewed the structure of a project within the Project Navigator and were introduced to the terms and concepts that are essential to working within a project environment. You then added a palette for your project from the Content Browser.

In the remainder of this tutorial, you create a project template, which you reuse for buildings of the same type (small office project).

Next, you define the building elevations in the Project Navigator. You work in the Project Navigator for the remainder of the tutorial to develop and document your building model.

**Lesson 2: Setting up Your Project Template**

In this lesson, you create a new project and refine it for use as a template. You use drawings from a previous project to establish standards for object styles and create project tools. You learn how to quickly convert linework sketches to building objects using tools.

This lesson shows how to define building levels and add categories to the Small Office Building template. The additions you make to your project environment and building model in this lesson lay the groundwork for developing future projects and managing their project standards.

As you set up a new project, you work with two key components of the project environment: the Project Browser and the Project Navigator. In the last lesson, you used the Project Browser to create the new project. In this lesson, you define building elevations and categories for the new project using the Project Navigator.
**Exercise 1: Creating a Project Template**

In this exercise, you create a new Architectural Desktop project that you will use as a template for the small office building project that you will create later. The project structure stores not only project drawings, but also:

- a Content Browser library for project tools
- content files for the tools (projects walls, doors, and windows)
- a custom tool palette with project-specific tools
- project standard styles for AEC objects

Structuring a project in this manner allows it to be archived or transmitted to others with all the required content under one project folder. It can also be used as a project template, so that if you created a project for a building type, such as schools, then you could re-use the project and have all the custom tools available when you begin the new project.

At the end of the exercise, the project will be structured as shown:

![Project Structure Diagram](image)

Create a new project to develop as a template

1. On the File menu, click Project Browser or click on the Navigation toolbar.
   Use the default project folder `c:\my documents\autodesk\my projects`.

2. In the lower left corner of the Project Browser, click on the Navigation toolbar.

3. On the Add Project worksheet, specify the following information:
   - Enter `ADT101` for Project Number.
   - Enter `Small Office Building` for Project Name.
   - Enter `A prototype project for commercial office space` for Project Description.

4. Clear Create from template project, and click OK.
You have just created a project folder with a file to track project drawings (*.apj), a file to manage project sheets (*.dst), and folders for different drawing types. These files and folders for storing project drawings were created automatically: you did not have to work outside Architectural Desktop to create them.

5 View the current project in the Project Browser

The project is now using the locations of the installed product for the bulletin board, project image, and templates. There are no automatic standards, project Content Browser library or project-specific tools. Tools are delivering content from the styles drawings. If you want to apply standards to the project, including templates, standards (object styles and AutoCAD), and add Content Browser library and tools, you can create these on a project by project basis. The paths to content are definable for each project so that you can decide on any combination of company-wide content (templates, standards, Content Browser library, tools) and content that is project-specific. If you want to create a project where templates, bulletin board, standards, and tools are project-specific, you can. The benefit to this approach is that you can ensure that all required content is stored under a project folder so you can more easily transmit whole projects with tools and standards. You can also use a project as a project template for a specific building type, such as a commercial office, school or hospital template.

6 In the Project Browser, click Close.

The Project Navigator is displayed, with the Small Office Building project current and a project palette group is created automatically.

**NOTE:** The project tool palette group is created, but not displayed in the tool palettes set, because it does not yet contain any tool palettes. To add tool palettes, and make the tool palette group visible, click in the tool palettes set title bar, click Customize, and add a palette to the project group in the Customize dialog box. When you click Close, the project tool palette group can now be selected in the tool palettes set.
7 With the Project Navigator open, click the Project tab.
8 Define a location for project tool palettes

Click in the Project title bar to display the Modify Project dialog box.
9 Click in the Tool Palette File Location field and click the browse icon that is displayed.

10 In the Browse for Folder dialog box, navigate to the My Documents/Autodesk/My Projects/Small Office Building folder and view the folder structure. With Small Office Building folder selected, click OK. This is where you will keep project-specific tool palettes - within your project.
12 Click in the Tool Palette Storage Type field and select Per user workspace. This will allow you to change your palettes without affecting anyone else.

13 Create or define a location for tool content (object styles)
In the Tool Content Root Path, click the Browse icon.

14 In the Browse for Folder dialog box, click the Small Office Building folder and click Make New Folder. Make a new folder named Standards, and then make the subfolders Object Styles and ACAD_DWS in the new Standards folder.

These folders are where you will store drawings containing project-specific object styles or AutoCAD DWS files. The tool content path should be to the folder with drawings containing object styles. With the object styles in standards drawings at this location you can both apply those standards across all project drawings and create project tools that use the standard object styles. The benefit to you is that you can manage object styles in one location. Changes to an object style will immediately update the tool and you can, through a process of validation, apply versioned standards across all project drawings. A change to a wall style, such as a change in materials, in the drawing identified as a standards drawing can be applied across all project drawings. The scenario, in this tutorial, is to keep the process simple with one drawing for standards and project tools and one location under the project folder. In this way the entire project can be managed as a self-contained project.

Later in this tutorial you will place a drawing containing object styles in the Object Styles folder. You will configure the object styles within that drawing as project standards and you will generate project tools from the standards drawing.

**TIP:** The folders do not need to be in your project, and you can have multiple locations for project standards. Wherever your standards are, they can be applied to all project drawings. For example, you can ensure that any specific window style with its materials is the same in all project drawings. Changing it at the source will allow it to be updated in all project drawings.

15 With the Object Styles folder selected, click OK twice.

16 Create a new Content Browser library for your project

On the Project Navigator, click .
17 In the Content Browser, right-click, and click New Library.
18 Change the Save in: location to your project folder (Small Office Building).
19 In the Create New Library dialog box, enter Small Office Building for File Name.

![Create new library dialog box](image1)

20 Click Save. You created the project Content Browser library but you have not completed the project data to locate the library.

21 Minimize the Content Browser.

22 Locate the Content Browser library for your project

On the Project tab, click in the Project title bar.

23 In the Tool Catalog Library field, click the Browse icon.

24 In the Tool Catalog Library dialog box, browse to the new project folder and select Small Office Building.cbl.

![Tool Catalog Library dialog box](image2)

25 Click Open.

26 In the Modify Project dialog box, click OK.

27 Verify the project library is connected

On the Project Navigator, click the Content Browser icon.
This is an empty library where you can add content. By creating the separate library, you control the content seen by the project team. You reduce the time in searching for content because you can limit the amount of content and ensure it is relevant to the project. The Content Browser icon on the Project Navigator locates the defined project library, whereas the Content Browser icon on the Navigation tools locates the library for all the delivered content.

28 Add a catalog to your library
   Right-click in the Content Browser and select Add Catalog.

29 To add an existing catalog, click Browse and select \my projects\small office building\small office building.atc. The catalog with a project tools group was created automatically when you created the project.
   The items that are currently not beneath your project folder are the bulletin board, project image and template files.

30 Copy files from the installed tutorial projects for use in your project.
   Open Windows Explorer and browse to the \my documents\autodesk\my projects\small office building folder.

31 Create two new folders named Templates and Supplemental in the Small Office Building folder.

32 Copy files from the folders in Small Office Building_M to the corresponding folder in your project. The files you need are in the Object Styles, Supplemental, and Templates folders.

33 Minimize Windows Explorer.

34 Locate the project bulletin board and project image
   On the Project tab, click in the Project title bar.

35 In the Bulletin Board field, click the Browse icon.

36 In the Bulletin Board dialog box, browse to the \my documents\autodesk\my projects\small office building\supplemental folder and select Small Office Building.htm.

38 For the Project image, browse to the same folder and select logo.bmp. You could include your client’s logos for the project.
39 Locate template files for project drawings
   In the Default Construct Template field, click the Browse icon.
40 In the Default Construct Template dialog box, navigate to the my documents\autodesk\my projects\small office building\templates folder and select AEC Model (Metric.Stb).dwt.
41 Click Open.
42 In the Default Element Template field, click the Browse icon.
43 In the Default Element Template dialog box, navigate to the my documents\autodesk\my projects\small office building\templates folder and select AEC Model (Metric.Stb).dwt.
44 Click Open.
45 In the Default Model View Template field, click the Browse icon.
46 In the Default Model View Template dialog box, navigate to the my documents\autodesk\my projects\small office building\templates folder and select AEC Model (Metric.Stb).dwt.
47 Click Open.
48 In the Default Section/Elevation View Template field, click the Browse icon.
49 In the Default Section/Elevation View Template dialog box, navigate to the my documents\autodesk\my projects\small office building\templates folder and select AEC Model (Metric.Stb).dwt.
50 Click Open.
51 In the Default Detail View Template field, click the Browse icon.
52 In the Default Detail View Template dialog box, navigate to the my documents\autodesk\my projects\small office building\templates folder and select AEC Model (Metric.Stb).dwt.
53 Click Open.
54 On the Modify Project Worksheet, click OK.

**TIP:** There is a structural template which contains a display configuration for working with structural members. This was used for the Steel-Framed Residential project.

**Exercise 2: Adding Legacy Drawings to the Project**

In this exercise, you add two "legacy" drawings (DWGs) to the current project. The drawings represent sketches of the first floor shell and typical core that you want to use to create the first floor shell and core of the current building project. You can include AutoCAD and AutoCAD LT drawings in your project and manage them in the Project Navigator. These exercise files are included to show you how to add existing drawings to a project and how to use existing linework to create AEC objects quickly.

To copy the drawings to the project, you hold the CTRL key and drag them from the tutorial dataset folder, named LegacyDrawings, using Windows Explorer, to the project folders in the Project Navigator. The first floor shell sketch represents a unique location in the building model (the first floor), so you add it to the project as a construct. Because you will use the core sketch to create core geometry that you will reference onto each floor of the building to form the core, you add it to the project as an element.

**Drag the drawings into the project navigator**

1. With the Project Navigator open, click the Constructs tab.
   The Constructs tab contains two folders, Constructs and Elements, where you will add the two drawings.
2. Open Windows Explorer and navigate to the my documents\autodesk\my projects\small office building_M\legacydrawings folder.
   The two drawings that you add are X-Sketch_01 Floor Shell_M.dwg and X-Sketch Typical Core_M.dwg.
3. Minimize Windows Explorer on your screen so you can view both the drawings in the Explorer and the Project Navigator in Architectural Desktop.
4 In Windows Explorer, press and hold CTRL, select both drawings, and drag them to the Elements folder.

5 On the Add Element worksheet, click OK to add the first drawing to the project as an element.

6 Click OK again to add the second drawing to the project as an element.

Both drawings are now added to the project as elements. Because the first floor shell drawing has a uniquely assigned location in the building model, you must reassign it as a construct in the project.

7 Reassign the first floor shell sketch to the project as a construct
   Under Elements, select the X-Sketch_01 Floor Shell_M.dwg file and drag it to the Constructs folder.

8 On the Add Construct worksheet, under Assignments, use the scroll bar on the side of the box to view Level 1.

9 Select Division 1 and click OK.
The first floor shell sketch is now added to the project as a construct and assigned to the first floor of the main building (division 1) within the project.

10 Add a drawing with object styles
Open Windows Explorer and copy the Styles_STD.dwg file in the my documents/autodesk/my projects/small office building_M/standards/object styles folder to the my documents/autodesk/my projects/small office building/standards/object styles folder. You will use the styles in this drawing to configure standards and to generate project tools.

The first floor shell sketch is now added to the project as a construct and assigned to the first floor of the main building (division 1) within the project. The legacy drawing representing a collection of styles you wish to be standard has been copied to your project.

In this exercise, you added sketches of the first floor shell and typical core geometry that you want to reference on each floor. You also copied a drawing containing objects to the standards/object styles folder. You will use this to create project specific standards and tools. In the next two exercises, you create project standards and tools and you use the sketches to create finished objects in each drawing by converting linework.

**Exercise 3: Configure Project Standards**

In this exercise, you define drawing files for project standards. In this example we are using our project standard Styles_STD.dwg file for all AEC objects.
Open the Small Office Building Project
1 On the File menu, click Project Browser to open the Project Browser dialog box.
2 Double-click Small Office Building to set the project as active.
3 Click Close.
4 Configure Project Standards
   Select Configure Standards. These standards can be for AEC object styles and AutoCAD standards. The Configure AEC Project Standards dialog box opens.
5 Select Enable project standards for project ADT101 - Small Office Building.

   ![Configure AEC Project Standards dialog box]

6 Select the AutoCAD Standards tab to verify that you can add an AutoCAD DWS file for AutoCAD standards. This would be used to apply standards such as for linetypes, text styles, or dimension styles.
7 Select the Standard Styles tab.
8 Verify that All Objects is displayed for Select which objects to display in the list below.

   **TIP:** You can specify multiple drawings for standards. You can define which AEC styles you see in the list (All Objects, Architectural Objects, Documentation Objects, and Multi-Purpose Objects), and you can select the style in the displayed list. In practice you could be more granular in how you organize the standards, for example having a Walls_STD.dwg and a Structural_STD.dwg. When you have multiple drawings for standard validation and the same AEC style, for example wall styles, is checked in more than one standard file, then the order of the drawings is important with the priority being assigned to the leftmost standards drawing. Validation checks the drawings from left to right, so the first selected drawing that has the style type selected is used as the standard.

9 Click Add Drawing. The minus removes drawings and the order can be changed if you assign multiple standards. The Select Standards Drawing dialog box opens.
10 Navigate to the My Documents/AutoCAD/My Projects/Small Office Building/Standards/Object Styles folder and select Styles_STD.dwg.
11 Click Open.
   The Styles_STD_dwg is displayed in the Standards Drawings column heading.
With All Objects selected, select all style types. When you use the Style Manager you will see the Styles_STD.dwg listed as a standards drawing for the project. Styles within the standards drawing that are checked as standard styles will display in the Style Manager with a blue color.

13 Configure the standard for display settings
In the Select drawing to use for standard display settings list, select Browse.

14 Navigate to the my documents/autoCAD/my projects/small office building/standards/object styles folder and select Styles_STD.dwg.

The Styles_STD.dwg file is your source for display configurations. This gives you one location where you can make changes and apply them to all project drawings.

**TIP:** You can locate standard files in the project folder or anywhere on your network. Since you can define multiple standards drawings, you can combine office standards from a location on your network with project-specific standards, in this case, located in the project folder. Make sure that the standards files are not located on a mapped network drive; the Drawing Management feature cannot use files from a mapped network drive.

15 Click Open.
16 Decide how the standards validation should be applied to project drawings
Click the Synchronization tab.

The options on this tab are as follows:

- **Automatic**, where you see no confirmation of updating standards which are validated when you open a project drawing.
- **Semi-automatic**, where you see a dialog box when you open a project drawing and you decide which items to update.

If you select Automatic or Semi-Automatic synchronization, the synchronization dialog can also appear upon saving and closing a project drawing, provided there have been changes to the standards.

- **Manual**, where you must initiate validation, the standards check, and confirm changes in the synchronization dialog box.
Select Manual.

Clear Create log file.

If selected, this would create an .htm or .xml log file that documents changes as you validate.

Click OK.

In the Version Comment dialog box, enter Initial Standards.

Click OK. All the styles are versioned automatically with today's date when you define a drawing as a standard. From this point on, you can manage the styles individually, versioning a standard and updating the standards from the project drawings. The technique for managing the standards is through use of the Style Manager.

Exercise 4: Generate Project Tools from a Project Standards Drawing

In this exercise, you create tools for your project catalog from the standards drawing Styles_STD.dwg.

Generate project tools

1 On the File menu, click Open.

2 Browse to the my documents/autodesk/my projects/small office building/standards/object styles folder, select the Styles_STD.dwg file, and click Open.

This is the standards drawing that contains the styles that you will use for your project tools. You created this from a legacy drawing for the building type.

3 On the File menu, click Close to save the drawing. The project should be active but the drawing does not need to be open.
TIP: All the styles in the drawing are available for creation of tools. You can see all the styles in the Style Manager. You would purge the drawing to remove unwanted styles so as to avoid creating unwanted tools. You also do not have to have the styles placed in the drawing, as they are in our tutorial file. The intention in leaving them was to visually confirm we are creating a project template for an office. You would repeat this process for other building types that you specialize in, where you want custom tools according to the building type.

4 On the Window menu, click Pulldowns ➤ CAD Manager Pulldown.
5 On the CAD Manager menu, click Tool Catalog Generator.
6 In the Populate Tool Catalog from Content Drawings dialog box, under Catalog, select Create a new catalog.

![Image of Populate Tool Catalog from Content Drawings dialog box]

7 Under Catalog, click Browse.
8 In the Browse for Folder dialog box, navigate to the My Documents/Autodesk/My Projects/Small Office Building folder and click OK.
9 Under Content Source, select Create from drawing.
10 Under Content Source, click Browse.
11 In the Browse drawings in folder for styles dialog box, navigate to the My Documents/Autodesk/My Projects/Small Office Building/Standards/Object Styles folder, select Styles_STD.dwg, and click Open.
12 Under Tool Organization, select Group tools by object type and Create tools in Categories.
13 Under Create tools for the following objects, verify that all of the objects are selected.
14 Click OK. Tools are created for you automatically and much more quickly than creating tools manually.
15 On the Project Navigator, click Content Browser.
   If your new catalog is not displayed in the Content Browser main window yet, you need to add it to your user library.
16 Right-click into the main window of the Content Browser, and click Add Catalog.
17 In the Add Catalog dialog box, select Add an existing catalog or web site, and browse to the catalog (ATC) you created in the previous steps. Then, click OK.
   The new catalog is appended to the list of catalogs in the Content Browser. Tools can be dragged as needed from the library to your project palette.
18 Close Content Browser.
Exercise 5: Defining Building Levels

After you have created and selected the current project environment in the Project Browser, you work in the Project Navigator to create and document your building model. You begin by defining the building’s vertical segments, or levels. This exercise shows how to use the Project Navigator to define the number of levels, their floor-to-floor heights, and their floor elevations.

Each construct in a building model is assigned to one or more levels. When you assemble a multi-level view from these constructs, the level assignment for each referenced construct is used as the Z coordinate insertion point for the construct. For example, when creating multi-level views, each construct is referenced at its level height.

Create new levels

1. With the Project Navigator open, click the Project tab.

2. Click in the Levels title bar.
   As a default, the first level is already present in each new project. The first level has a floor elevation of zero and represents the ground floor.

3. Adjust the properties for the first level:
   - Under Name, double-click the default value, and enter G.
   - Under Floor to Floor Height, click the default value and enter 3750.
   - Verify that ID is 0.
   - Under Description, enter Ground Floor.

4. Verify that Auto-Adjust Elevation is selected, and click to add a new level.
   When Auto-Adjust Elevation is selected, each new level takes its floor elevation from the height of the level below it.

5. Adjust the properties for the second level:
   - Under Name, double-click the default value, and enter 1.
   - Verify that ID is 1.
   - Enter 1st Floor for Description.

6. Click to add the third level, and then adjust its properties:
   - Under Name, double-click the default value, and enter 32.
   - Verify that ID is 2.
   - Enter 2nd Floor for Description.

7. Add the fourth level, and adjust its properties:
   - Under Name, double-click the default value, and enter 3.
   - Verify that ID is 3.
   - Enter 3rd Floor for Description.

8. Add the fifth level, and adjust its properties:
   - Under Name, double-click the default value, and enter 4.
   - Verify that ID is 4.
   - Enter 4th Floor for Description.

9. Add the sixth level, and adjust its properties:
   - Under Name, double-click the default value, and enter R.
   - Verify that ID is 5.
   - Enter Roof for Description.

10. Verify that the level properties are correct:
11 Click OK.
12 If you are prompted to regenerate views in the project, click Yes.

This ensures that the views are based upon the updated level information.

In this exercise, you added the levels for your building project. You defined the number of levels, their names, IDs, and descriptions, their floor-to-floor heights, and their floor elevations. The name of the level is the unique identifier of the level that is used when assigning constructs. The level ID can be used in schedules. You can add and remove levels at any time during a project. The project is updated with the new level information.

Next, you create the categories that are used to organize all the project files you work with in this tutorial.

The structure of your project is set up. Next, you begin developing your building model.

### Exercise 6: Categorizing Portions of Your Project

As you have seen, categories are sets of folders in a tree structure within a project that allow you to organize your project files. At the highest level in this tree structure, each building project has a project folder, which bears the name of the project. Within the project folder, there are four default folders: Constructs, Elements, Views, and Sheets. To help you organize your building model data and reports, you can create categories and subcategories for constructs, elements, and views. You can also organize the plotting sheets for your project by creating sheet subsets. This exercise shows how to create the categories that are used to organize the project files for the Small Office Building project.

You can create categories and subcategories directly in the Project Navigator. You determine the number of categories and subcategories, and the scheme for naming them, based on your project-specific needs. For this project, you create construct categories by discipline: Architectural and Structural. Then, within each category, you create subcategories, such as Building Outline, Partitions, and Shell, to hold the relevant constructs. You create some of these constructs as you work through the exercises in this tutorial; others are added to the appropriate categories when you update your project files.

#### Create categories for constructs

1. The tree structure for the new project does not contain any construct categories or subcategories in which to place the constructs that are added throughout this tutorial. This exercise shows how to create the two major construct categories you use in this tutorial, Architectural and Structural, and how to add their subcategories.
   
   With the Project Navigator open, click the Constructs tab.

   2. Select the Constructs folder.

   3. Click at the bottom of the Constructs tab.

   You can also right-click the Constructs folder, and click New Category.

   4. Enter Architectural for the category name, and press ENTER.
The Architectural subcategory under the Constructs category

5 Follow the same process to add another category under Constructs, and enter **Structural** for the name of the category.

6 Select the Architectural folder, and add a category named **Building Outline**.

7 Add two more categories under Architectural, and name them **Partitions** and **Shell**.

8 Select the Structural folder, and add a category named **Column Grid**.

9 Add another category under Structural, and name it **Slabs**.

10 Verify that the Constructs categories are correct:

11 To make changes, you can move, rename, or delete a category:

- Move a category by dragging it to a new location.
- Rename a category by clicking the current name, and then clicking it again to enter a new name. You can also select the category, right-click, and click Rename, and enter the new name.
- Delete a category by selecting the category, pressing DELETE, and clicking Yes to confirm the deletion. You can also select the category, right-click, and click Delete, and click Yes to confirm the deletion.
NOTE: If you rename, move, or delete a category that contains constructs or elements, or if you change the name or location of individual constructs and elements, you change the external references within your project. If you make name and location changes, you need to update the external references throughout the project by clicking the Repath Xref icon ( ) at the bottom of the Constructs tab. If you make name or location changes and do not re-path the project, the software prompts you to re-path when you switch to a different project.

Although you can create subcategories under the Elements category, they are not needed for the Small Office Building project because it uses only one element. Next, you create categories for views.

12 Create categories for views
   Click the Views tab.

13 Select the Views folder, and add a category named Exterior.

14 Add another category under Views, and name it Interior.

15 Verify that the Views categories are correct:

![Image of Views categories]

16 If you need to make changes, refer to step 11.

Exercise 7: Creating a Project from a Project Template

In this exercise, you create a new project for the office building type by using your project template.

Create a commercial office project

1 Click .

2 On the Add Project worksheet, specify the following information:
   - Enter OFF101 for Project Number.
   - Enter Commercial Office for Project Name.
   - Enter Project created from your template for Project Description.

3 Select Create from template project.

4 Browse to my documents\autodesk\my projects\small office building and select Small Office Building.apj.

5 Click OK. A new project is created and it is ready for the design phase as it has configured standards, a project Content Browser library and project tools for the office building type.

Exercise 8: Create the Core and Shell from a Sketch Using Tools

In this exercise, you use the linework sketches that you added to the project in a previous exercise to create the typical building core element and shell construct. It is not required that you start with a line drawing, but this technique shows
how you can leverage your existing AutoCAD skills and move quickly from a line drawing to generic or fixed object styles. The fixed object styles are the ones that you would be appropriate for schedules. As you proceed with the design you are moving from the general to the specific. For this exercise you can use the Commercial Office project.

**Draw walls**

1. With the Project Navigator open, click the Constructs tab.
2. Under Elements, double-click X_Sketch_Typical_Core_M. This is the element drawing that contains the core sketch.
3. In the left viewport, zoom in around the first room on the left side of the core plan. In the next steps, you trace over the outline of the room to add walls.

![Room Sketch](image)

4. Move your cursor over the tool palettes set title bar. If Auto-hide is on, the tool palettes set will expand. The tool palettes set, where you access the tools that you use to create your drawing, is organized into function-specific palettes containing the tools.
5. Move your cursor off the tool palettes set and into the drawing area. If Auto-Hide is on only the palette bar displays.
6. The tool palettes set minimizes so that only the palette title bar is displayed. You may find that minimizing the palettes set is helpful when you are working in the drawing area, or you display the full palettes set by clicking Auto-Hide.
7. Move your cursor back onto the tool palettes set, click the stacked tabs to display the list of available palettes, and click Design. The tabs "stack" at the bottom of the tool palettes set when there are more tool palette tabs than can be displayed within the current height of the tool palettes set. The list that is displayed when you right-click on the tabs shows all available palettes in the group. The tab names displayed below the line on the list are the ones that are hidden in the stack.
8. Right-click on the tool palettes set title bar and select Design.
9. Click the Wall tool on the top left of the palette.
11. Use an Endpoint Osnap and start in the upper left corner.

![Wall Drawing](image)

12. Draw in a clockwise direction and pick the remaining corner points, closing on your start point.
13 Click in the right viewport and zoom in on the new walls.

14 Select the new walls and press Delete.
15 Convert the core plan sketch linework to walls
   Click the left viewport, and zoom to extents.
16 On the Design tool palette, select the wall tool, right-click, and click Apply Tool Properties to Linework.
17 Use a crossing selection to select all of the floor plan linework.
18 Accept the default, No, to retain the layout geometry linework.

19 With walls still selected, on the Properties palette, under Dimensions, change the Base Height to 3500 and select
   Left for Justify.
20 Press ESC.
   View the new walls in the right viewport.

21 In the left viewport, zoom in on the left side of the floor plan.
22 Use project tools
   Right-click on the tool palette bar and select Commercial Project.

   **TIP:** If you had a project group but were unable to see it listed that would be because the project group contains no palettes. By default, in a new project, you have a project group and a project tools palette with a link to Help. Drag any palette onto an empty group and it will be listed when you right-click on the tool palette bar.

23 With the Commercial Office palette group active, right-click on the palette bar and select New Palette.
24 Enter MOST USED for the new palette name.
25 On the Project Navigator, click the Content Browser icon.
26 From the appropriate category, drag the wall style CMU-190 and the door style Hinged-Single onto your MOST USED palette.
27 Click CMU-190, right-click, and then click Apply Tool Properties to Wall. These styles are from your project standards.
28 Select the four interior walls you selected previously.

![Diagram of selected walls]

29 The selected walls now have the CMU-190 style applied to them.

![Wall Properties dialog box]

30 Press ESC.

![Diagram showing walls after ESC]

31 Right-click on the tool and select Properties to confirm that the tool is delivering a style from project standard object styles.
32 Draw doors using dynamic dimensions.
You create three doors 150 from the room corners beside the stair shaft. On the Design palette, click the Door tool. Walls are generally drafted with Osnaps, so that you are making sure that walls meet precisely. For placement of doors, windows and openings you can turn off OSNAP, ORTHO, POLAR, OTRACK but leave DYN on.

33 Select the wall segment, then use the TAB key to change focus to the dimension you want to be active. When you have the dimension to the left of the door, enter 150. You control the door swing direction with the location of the cursor as you place the door but you can also easily change this at any time with grips.

34 Repeat steps 32-33 to place a door on the hatched wall.

35 Repeat steps 32-33 for a third door but specify 300 from the corner. You placed three generic doors. In a schedule they would list as “Standard”.

36 Replace generic doors with doors of a fixed style
On the MOST USED palette, right-click Hinged-Single, and click Apply Tool Properties to Door. Then, select all three doors.

37 With the three doors selected, in the Properties palette, select 1000x2100. Generic or standard doors had user defined sizes but fixed style doors have a listing of manufactured sizes. They also have materials assigned, so as you refine a design from standard styles to fixed styles the information and representation of the objects is more exact. If you know what the finished components are then you can bypass the use of the generic styles. Styles are easily changed at any time.

38 Grip edit the doors
Click on a door and click grips to make changes. Tool tips explain the function of the grips. Change the door swings to match the illustration - exit doors opening outwards. The grips let you change location, size and direction. The grey lines that appear on selection of the size grip, show the manufactured widths available for the door style.
Reposition existing doors, windows or openings
The location of doors, windows and openings are easily changed. One drafting technique is to place multiple doors approximately, then define style and location by editing each. Select the door on the right and right-click.

Select Reposition Along Wall.

Running Osnaps should be off. Click to select the line of placement on the door (left end) then use an End Osnap to select the corner of the room.

Enter 900 for the distance.

**TIP:** You can right-click on a wall, select AEC Dimension and place a dimension string that updates as walls, doors, opening are edited. In some situations this may be useful as you can see the dimensions change with every edit. Delete the dimension when finished. Dimensioning would typically be created in a View drawing.

Create an opening using offset/center
Click on DYN. Dynamic dimensions are off.

As an alternative to dynamic dimensions, in the Properties palette, you can change Position along wall from Unconstrained to Offset\Center.

On the Design palette, click Opening.
In the Properties palette, change Width to 1100 and Height to 2100. Change Position along wall to Offset\Center and enter 600. Without using Osnaps, this lets you place objects a specified distance from a corner or opening and if you click near the middle of a wall segment, centered. You only need to pick close to the end, opening, or center of a wall segment to get precise placement. Osnaps are not needed.

Place all four elevator openings.
48. Convert remaining linework to walls
   Select all the small rectangular shapes above the diagonal line.

49. Click on one of the lines.

50. In the Properties palette, change the Height to 3500. Change the style to W2 and justification to Left. These styles are already in the drawing so they list as an option in the Properties palette.

   **TIP:** Linework has a beginning and end, so it has a direction. In this case it is known how the linework was drafted so it is possible to predict which side of a line a left-justified wall will be placed. If you plan on using linework sketches you would establish some rules as to drawing direction so that placement is predictable.

51. Repeat for the circles below the diagonal line but select the style col_covers, set Justification to Center and Height to 3500.

52. Turn off layers SKETCH and SKETCH LOCKED.

53. Close and save the drawing.

54. Open the drawing for the building shell and create walls and curtain walls.
   Double-click the construct X-Sketch01 Floor Shell_M.

55. Right-click on the tool palettes set title bar, and click Design. On the Design palette, right-click on the curtain wall tool and select Apply Tool Properties ➤ Referenced Base Curve.

56. Click on the two green polylines to convert.

57. In the Properties Palette, change Base height to 3750 (Floor to Floor Height) and Justification to Center. This standard curtain wall is already in the drawing with assignments of doors for an infill panel.

   **TIP:** To make any object available in a drawing, you can use a tool to create the object and the style is saved within the drawing. The placed object can be deleted but the style definition still resides in the drawing. This is one technique to introduce material styles. If you place a door with an ash material then the material style is introduced with the door.

58. On the Design palette, right-click the Wall tool and select Apply to Linework.

59. Select the remaining yellow linework.

60. The drawing has a Brick-exterior style. In the Properties palette, change the style to Brick-exterior and the Base height to 3750.

61. Zoom in closely to the curved curtain wall and click on the underlying curved polyline.

62. Click to select the middle location grip and move it outwards.

63. The curtain wall updates to reference the new base curve.

64. Enter U until the curtain wall return to its original position.

65. Close and save the drawing.

66. Reference the element to the construct.
   In the Project Navigator, click the Constructs tab.

67. Drag the element icon X-Sketch Typical Core_M onto the X-Sketch_01 Floor Shell_M.

68. Double-click the construct X-Sketch_01 Floor Shell_M to open the drawing and confirm you have a service core element (reusable on other floors) within the building shell for floor 01.
Close and save the drawing.

In this lesson, you explored project structure looking at categories and the drawing types (elements, constructs, views and sheets) that together constitute a project. You added a palette and tools to your default tool palettes from the Content Browser. You then created a project and refined it for use as a project template. That project template included project standard styles and project tools that deliver the project-specific object styles to your drawings. You defined the levels for your building model and added categories to the project. By defining levels, you established the values that are used to “assemble” the building model when you create views later. The categories and subcategories you created are folders within the project folder that are used to organize the drawings that make up your project. These folders hold the constructs and views that you create directly in the Project Navigator, or that you add. You added legacy drawings for use in the exercises, just as you would add drawings from a consultant or because you wish to include regular AutoCAD files and you quickly converted linework to a drawing with walls, doors, openings and curtain walls.

Categories help you organize your project files, whether they are constructs, elements, views, or sheets. Categorizing constructs also gives you additional labels for the constructs that can be used when generating views. When you create views of your building data, you can use categories as a selection criterion. For example, for a complete view of all framing constructs in your building, you could set up a view that references the Framing subcategory, thereby referencing all drawing files from that category. If you add more framing drawings to the Framing category later, the view is updated automatically when you regenerate it. You can organize the plotting drawings for your project by creating sheet subsets in the Sheet Set View. Using construct categories in this way can help ensure that all members of a project team reference the proper files.

The structure of your project is set up. Next, you add manage project standards.

Lesson 3: Managing Project Standards

In this lesson, you manage the object styles that are now a project feature. Both tutorial datasets include configured standards. The dataset used for this chapter is the Steel-Framed Residence. You version all the project styles, and then manage the changes.

Exercise 1: Versioning, Validating, and Updating Project Styles and Definitions

In this exercise, you create a new version of the project standard styles, manually validate an individual drawing against the standards so you can see how the feature works, validate all styles in all project drawings simultaneously, and update all project drawings so they have the latest versions of all the object styles.

Project standards are a major time-saver as they provide you with a way to manage project standards in one location and apply them to project drawings. How the standards should be configured and applied is a decision for your CAD Manager. Be sure to consult with him or her regarding the process that is the best fit for your organization.
Open the Steel-Framed Residence_M project
1 On the File menu, click Project Browser. The Project Browser is displayed.
2 Double-click Steel-Framed Residence_M. The bulletin board and the project information in the browser updates for the project.
3 Click Close to exit the Project Browser.
4 Use the Style Manager to apply a version to project object styles On the Format menu, click Style Manager.
5 In the tree view, expand the project standard icon for STL101-Steel_Framed Residence_M.
6 Expand the standards file, Styles_STD.dwg.

7 Right-click the standards file (Styles_STD), and select Version Drawing.
8 Click in the Version Comment field, and enter Initial Standards.

NOTE: Versioning is done automatically when you configure project standards for a new project. The reason you are doing it now is to create a new version of the standard styles in the existing project. This will allow you to validate against the latest version of standard styles and see how validation and updating works.

9 In the Version Objects dialog box, click OK.
10 In the Style Manager, click OK.
11 Click Yes to save the change to your standards.

12 Decide how to apply the validation
   Click on the AEC Project Standards icon , and select Configure Standards. The Configure AEC Project Standards dialog box opens.
13 Click the Synchronization tab.
14 Select Manual.
15 Click OK to exit the dialog box.
16 Validate manually
   In the Constructs tab, double-click to open any construct.

17 Click the AEC Project Standards icon.

18 Select Synchronize Drawing. The Synchronize Drawing with Project Standards dialog box opens.

19 Review the dialog box. You have older versions of styles in your current drawing because you applied a version to
   the standards today. You could change the Action field to keep any old versions of styles, should you want them.
   You will update them from the standards.

20 Leave the Action item at Update from Standard and click OK.

21 Validate and Update object styles in all project drawings
   On the Window menu, click Pulldowns ➤ CAD Manager Pulldown.

22 Select the Synchronize Project with Standards to update all your project drawings. The Analyzing Project Drawings
dialog box opens and runs the validation against all project drawings. The progress is reported in a dialog box.

23 The Synchronize Project with Project Standards dialog box opens. The top portion identifies non-compliant styles
   in project drawings. The bottom portion identifies any styles in the project drawings that do not exist in your
   standards.
24 Click OK to accept the default settings, updating the project drawings from the standard styles and skipping styles in the current drawing that are not standard. Skip ensures they are listed with validation while Ignore drops them from the list.

25 The Synchronizing Project dialog box opens and the changes are completed.

26 On the Window menu, click Close All. The AutoCAD dialog box opens.

27 Click Yes to save changes. Changes are not made until the files are saved. You will not see changes in view drawings or sheets until the changes are saved.

**Exercise 2: Modifying a Standard Style and Updating the Project**

The purpose of this exercise is to show that, while working on project drawings, styles can be edited, uploaded to the standard files and subsequently applied to all project drawings. The example chosen is visual so you can see the style changes. A material definition called “paint” which has a red material image is changed to a white paint image. By updating project drawings all the structural members having the paint material are changed to a white paint finish.

**Open the Steel-Framed Residence Project**

1. On the File menu, click Project Browser.
2. Double-click Steel-Framed Residence_M.
3. Click Close to exit the browser.
4. On the Constructs tab, double-click House Structure to open it in the drawing area.
5. Edit a material definition on a structural member
   - Right-click a column in the drawing.
6. Click Edit Member Style.
   - The Structural Member Style Properties - Column U203x203x46 dialog box opens.
7. On the Material tab, click the Edit Material button.
   - The Material Definition Properties - Paint dialog box opens.
8. Click the Edit Display Properties button.
9. Select the Render Material drop-list.
10 Select the WHITE PAINT item.

**NOTE:** You changed the material for the High Detail display representation.

11 Click OK three times.

12 Use the style manager to update the standards with the edited style.

On the Format menu, click Style Manager.

13 Expand the House Structure, Multi-Purpose Objects category.

14 Expand Material Definitions. The star on the paint definition indicates it is newer than the standard.

15 Right-click Paint.

The Material Definition Properties - Paint dialog box opens.

16 Select Update Standards from Drawing. The Update Project Standards dialog box opens.

17 Click OK. The dialog box opens to complete the update.

The star icon which indicated a newer version, has returned to normal. Click the OK button.

18 Click OK.

19 Click Yes to save the changes to the standard file.

20 Update all project drawings.

On the CAD Manager menu, click AEC Project Standards ➤ Synchronize Project with Standards.

The Analyzing Project Drawings dialog box opens, and then the Synchronize Project with Project Standards.

21 Click on the Action column header to change the order of listing. You should be able to see material paint style and the host drawings that are to be updated.

22 Click OK.

23 Confirm the material style changed in other drawings.

Click the Project Navigator and open other drawings to confirm the structural members have changed from a red finish (Materials.Structural Metal Frame.Steel) to a white paint.

24 On the Views tab, expand the Model category.
25 Double-click on any of the model category views to see that the structural steel has had its material changed to white paint.

26 Save the drawings.

27 In this exercise you made a change to a style, while in a project drawing, updated project standards with the revised material style and applied the style to all project drawings.
Creating a Steel-Framed Residence

This part of the tutorial shows you how you can use the features in Autodesk® Architectural Desktop 2006 to design and document a small steel-framed residence. You learn how to use Architectural Desktop to:

■ work within a project environment.
■ create, connect, and trim structural members.
■ apply materials to architectural objects in your drawings.
■ create automated construction documents that include sections, elevations, and annotation.
■ explore different techniques for communicating and sharing your designs.

To complete the exercises in the tutorial lessons, you use many of the new features in Autodesk® Architectural Desktop 2006.
Understanding the Tutorial Project

A project, Steel-Framed Residence_M, is provided with this part of the tutorial. The project contains the project drawings (elements, constructs, views and sheets) that support the design of the residence. You work in exercise drawings that are included in the project to complete the exercises in each lesson. Most of the exercise drawings that you work with are prefixed with an X. Completed drawings are also provided for some of the exercises as finished constructs or prefixed by XX.

Project standards have been applied to this project, and the project includes a tool palette group, Steel-Framed Residence_M. The tool palette group contains a Structural Member Styles palette that contains the structural member tools you use to design the steel-framed residence. You can also access a project-specific tool library in the Content Browser.

The four lessons in this part of the tutorial follow the typical workflow of an architectural project:

**Developing the Steel-Framed Residence**

This lesson focuses on the design development of the structural frame of the residence. You learn how to create, connect, and trim structural members using different method and options.

You also create the floor, roof, and ceiling slabs for the residence, and learn how to apply materials to them. You update the project standards with the new material definitions and then create a palette of project materials in the project tool group.

**Creating a Roof Enclosure and a Screen**

In the second lesson, you create, array, and trim structural members to create a roof for the residence.
When the roof is complete, you create a louvered screen between two of the columns of the frame, and add it to the project.

**Sharing Design Data**

In the third lesson, you explore different methods of communicating your design to others. You use a site plan to create a terrain model that depicts the uneven topography of the residence site. After you create the terrain model, you create a view that includes the terrain model and the residence frame. You export the geometry in the view to VIZ Render, where you create an animation that depicts the potential flooding that could occur on the site.

You learn how to create sections and elevations in the project and how to reference them onto sheets.
You finish the lesson by publishing two of your project drawings to 3D DWF™ files. DWF files, or Design Web Format files, are the Autodesk method of publishing 2D or 3D design data to the Internet or to an intranet. You can generate DWF files of your three-dimensional models with nearly the same visual fidelity as your original DWG files.

**Updating and Modifying Project Tools**

In the final lesson, you learn how to update and modify project-specific tools. You update the styles and definitions of the project tools, and create new tools. You learn how to make necessary modifications to the new structural member tools that you create.

**Opening and Exploring the Project**

After you extract the tutorial dataset, follow these steps to open the project:

1. On the File menu, click Project Browser.

   **NOTE:** You must have a drawing open to access the Project Browser. If you do not have a drawing open, click on the Standard toolbar to create a new drawing.

2. In the Project Browser, click if necessary to display the project folder. Double-click the lesson folder.

   **NOTE:** If you have been working with non-tutorial projects, you may need to browse to my documents\autodesk\my projects.

3. Double-click the project name, Steel-Framed Residence_M.
4. If you are prompted to re-path the project, click Yes.
5. In the right pane of the Project Browser, under Show me, locate the DWF and AVI files that describe the project.
6. Click one or more of the files to view them.
7. When you are finished viewing the DWF and AVI files, click Close to close the Project Browser.
8. On the Project Navigator, click the Project tab.
9. Under Current Project, verify that Name displays the correct project - Steel-Framed Residence_M.
10. Keep the Project Navigator open to begin the first lesson.

**Lesson 1: Developing the Steel-Framed Residence**

In this lesson, you create the structural steel frame and floor, ceiling, and roof slabs of a small residence. You create the residence frame in such a way that its structural members are connected and can be refined as the design progresses.

In the first three exercises in this lesson, you learn how to work with Architectural Desktop structural members to create the residence frame.
You learn how to create structural members from linework and grids, on edges, as fills between members, and from other architectural objects, such as walls, slabs, and roof slabs. You learn to connect structural members, automatically trim them as you create them, and trim them with specific trim options after you have created them.

In the final exercise in this lesson, you create the floor, ceiling, and roof slabs of the residence above and below the glass skin of the residence. After you create the slabs, you learn how to apply materials to both the slabs and the glazing members to make them look more realistic.

After you apply the materials, you add them to the projects standards. You create a new tool palette in the project tool group, Steel-Framed Residence_M, that contains the materials you applied.

**Exercise 1: Creating Connected and Trimmed Structural Members**

In this exercise, you create a small structural grid with attached Standard (generic) style columns and beams. You place four columns on the grid, and then connect the columns with beams. You learn how to automatically trim beams to column faces, how structural members connect, and how to miter connections between members to create clean joints.
Attach Standard style columns to a structural grid

1. With the Project Navigator open, click the Constructs tab.
2. Under Elements, double-click X-Structural to open it in the drawing area.

A small structural grid is displayed in two viewports in the drawing. The left viewport contains a plan view of the grid, and the right viewport, an isometric view of the grid.

3. Right-click the tool palettes set title bar, and click Design.
4. On the Design tool palette, click Structural Column, and attach four standard style columns to the grid:
   - On the Properties palette, under General, select No for Trim Automatically.
   - Under Dimensions, verify that Logical length is 3600.
   - Select Middle Center for Justify.
   - In the left viewport, select the four corners of the grid, and press ENTER.

The Standard style columns provide "generic" members that you can use when developing your designs. You replace the standard style applied to beams with a finished beam style later in the exercise.

5. Place trimmed beams between the columns
   - On the Design tool palette, click Structural Beam, and draw a beam between the columns on the right side of the grid:
     - On the Properties palette, under General, verify No is selected for Trim Automatically.
     - Under Dimensions, enter 0 for Roll.
     - Select Edge for Layout Type.
     - Select Top Center for Justify.
     - On the Format menu, click Drafting Settings.
     - On the Object Snap tab, turn off all Osnaps except Node, and click OK.
     - In the right viewport, select the tops of both columns on the right.
The beam is placed between both columns, but does not trim to the outer faces of the column. In the next step, you add a beam between the columns on the left side of the grid that will automatically trim to the column faces.

6 On the Design tool palette, click Structural Beam, and draw a beam between the columns on the left side of the grid:
   ■ On the Properties palette, under General, select Yes for Trim automatically.
   ■ Under Dimensions, verify Top Center is selected for Justify.
   ■ Select the tops of both columns on the left.
   The endpoints of both beam and column assemblies share the same location (start/end grips) and are logically connected. The Trim automatically setting has applied trim planes to the left beam which trim the beam to match the outer faces of the column.

7 Delete the first beam that you drew on the right side of the structural grid, and place trimmed beams between all four columns.

8 Move the grid to test connectivity between the grid, beams, and columns
Select the structural grid, select a location grip on one of the outer grid lines, and move the grid.
The grid uses manual spacing, so you can individually move the grid lines. The structural members remain attached to the grid and move with it because the justification line grips are coincident.
9 Substitute a finished structural member for the generic Standard style beams Right-click the tool palettes set title bar, and click Steel-Framed Residence_M.
This palette group contains a palette of project-specific tools named Structural Member Styles. The tools on this palette contain an I-Beam style that you want to apply to the standard style beams.
10 On the Structural Member Styles palette, right-click Beam RoofUB305x165x54, and click Apply Tool Properties to ➤ Beam.
11 Select all four beams, and press ENTER.
12 With the four beams selected, on the Properties palette, under Dimensions, select Bottom Center for Justify.
13 Enter 0 for Roll.
The I-beams are now placed on top of the column and you can view the effects of the automatically applied trim planes.
14. Press ESC.
15. Miter the beams
   Select one of the beams, right-click, and click Trim Planes ➤ Miter.
16. Select one of the connecting beams.
   Trim planes are generated to produce a mitered joint between the two beams.
17. Repeat the two preceding steps to miter the remaining three beam connections.

18. Place an array of secondary beams and test connectivity between members
   On the Structural Member Styles palette, select Beam RoofUB305x165x54, and array secondary beams between two of the existing beams:
   - On the Properties palette, under General, select No for Trim Automatically.
   - Under Dimensions, select Fill for Layout type.
   - Select Bottom Center for Justify.
   - Under Layout, select Yes for Array.
   - Select Repeat for Layout method.
   - Enter 1500 for Bay size.
   - Select the middle node of a beam.
   - Select the middle node of the opposite beam.
19 Press ESC to exit the command.

20 On the application status bar, turn off OSNAP.

21 Select an edge beam with connecting secondary beams, and move its location grip.

   Connectivity between structural members is hierarchical: beams are connected to columns and braces are connected to beams. You saw the structure move with the structural grid changes in a previous step, which moved the attached columns. If you move a primary beam, the columns are unaffected, but the connected secondary beams move.

   If you move a column, the connected beams move.
On the drawing window status bar, click the display flyout, and click Diagnostic. Grips within the green circles are connected.

**NOTE:** The radius for the connection circle is the unit size for the drawing. This is an inch in an imperial drawing and a millimeter in a metric drawing. Accurate drafting is important for connectivity between structural members.

---

**Exercise 2: Developing the Structural Frame from Linework**

In this exercise, you create the structural steel frame of the residence by converting linework to structural members. You begin by adding columns to a sketched grid.

After you add the columns, you convert the outer grid lines to a roof edge assembly. You change the elevation of the roof assembly to locate it at the tops of the columns.
When the roof assembly is complete, you create the floor structure.

Add columns to the grid
1 With the Project Navigator open, click the Constructs tab.
2 Under Constructs, double-click X-Structure from Sketch to open it in the drawing area.

3 Click on the Views flyout on the Navigation toolbar to display the top view of the grid.
4 On the Format menu, click Drafting Settings.
5 On the Object Snap tab, select Endpoint, and click OK.
6 Right-click the tool palettes set title bar, and click Steel-Framed Residence_M.
7 On the Structural Member Styles palette, click ColumnUC203x203x46, and add four columns to the top of the grid:
   - On the Properties palette, under Dimensions, enter 3200 for Logical Length.
   - Select No for Specify roll on screen.
   - Enter 180 (degrees) for Roll.
   - Select Top Center for Justify.
   - To add each column, select the endpoints of the grid lines within in the bubbles.

8 On the Structural Member Styles palette, click ColumnUC203x203x46, and add four columns to the bottom of the grid:
   - On the Properties palette, under Dimensions, enter 3200 for Logical Length.
   - Select No for Specify roll on screen.
   - Enter 0 (degrees) for Roll.
   - Select Top Center for Justify.
   - To add each column, select the endpoints of the grid lines within in the bubbles.

**TIP:** If you create the columns with incorrect properties, you can select the columns, right-click, and click Properties to edit their properties.

9 Create a roof structure
   On the Structural Member Styles palette, right-click Roof Edge Assembly, and click Properties.
   Tools have default placement, size, and behavior properties.

10 On the Tool Properties worksheet, verify the following default properties of the Roof Edge Assembly:
   - Under General, verify No is selected for Trim Automatically.
   - Under Dimensions, verify Baseline is selected for Justify.

11 Click CANCEL.
   The connections for the roof structural members is shown in the illustration. The column shape is top center justified, so the justification line is centered on the inside face of the I-Beam. The roof edge assembly, shown in section, was drafted with a member shape origin (baseline) defined at the location of the black circle. Think of it as a justification line coming out of the page towards you. The roof beam is middle center justified. All three justification lines meet.
12 On the Structural Member Styles palette, right-click Roof Edge Assembly, and click Apply Tool Properties to ➤ Linework.

13 Select the four outer lines of the grid, and press ENTER.

14 On the Convert to Beam worksheet, verify Erase Layout Geometry is cleared, and click OK.
   You use the retained linework in a later step to create the floor.

15 With the beams selected, set the following properties on the Properties palette:
   ■ Under Dimensions, select Baseline for Justify.
   ■ Under Location, enter **3100** for Elevation.

16 Press ESC.

17 On the Structural Member Styles palette, right-click Beam Roof UB305x165x54, and click Apply Tool Properties to ➤ Linework.

18 Select all thirteen of the inner lines in the drawing, and press ENTER.

19 On the Convert to Beam worksheet, verify Erase Layout Geometry is clear, and click OK.

20 With the beams selected, set the following properties on the Properties palette:
   ■ Under Dimensions, select Middle Center for Justify.
   ■ Under Location, enter **3100** for Elevation.

21 Press ESC.

22 Click on the Views flyout on the Navigation toolbar to display the model.

23 Test connectivity between structural members
   Select the long roof edge beam assembly, and move the central square location grip.
The secondary roof beams move with the roof beam edge assembly.

On the Standard toolbar, click \[\text{undo symbol}\] to restore the original position of the beam assembly.

The individual justifications of the roof edge beam assembly (baseline) and secondary roof beams (middle center) are coincident.

**NOTE:** You can extend and trim structural members if their justification lines are planar. They will be connected.

Select the camera, right-click, and click Create View.

Create the floor

Click \[\text{views symbol}\] on the Views flyout on the Navigation toolbar.

On the Structural Member Styles palette, right-click Beam Floor Edge RSC381x102, and click Apply Tool Properties to \[\text{linework symbol}\].

Select the four outer grid lines, and press ENTER.

On the Convert to Beam worksheet, click OK.

With the beams selected, on the Properties palette, select Middle Left for Justify.

Leave the elevation property in the Properties palette set to 0.

**NOTE:** The linework has a direction. Lines have a start and end point. To be consistent, linework should be drawn in the same direction, clockwise, for example, to ensure that the structural shape justification is the same for all lines.

Press ESC.

On the Structural Member Styles palette, right-click Beam Floor UB305x165x40, and select Apply Tool Properties to \[\text{linework symbol}\].

Select the thirteen internal lines, and press ENTER.

On the Convert to Beam worksheet, click OK.
36 With the beams selected, on the Properties palette, under Dimensions, select Middle Center for Justify.
37 Press ESC.
38 Use member connectivity to lower the floor
   Select the near floor edge beam (not the line), and click the square cyan location grip.
39 With the grip selected and OSNAP off, press CTRL until the Move Connected in UCS ZX plane is displayed.
40 Move the cursor down vertically, and enter 195.
41 Press ESC.
42 Repeat the steps to lower the back edge beam.

**NOTE:** You did this to show connectivity. To achieve the same result, you could have selected the two long edge beams and changed the elevation to -195 on the Properties palette. If you need to level the floor then select all the floor members and check that start and end Z values are correct with their minus values.

43 Lengthen the eight columns
   Select the eight columns, right-click, and on the Properties palette, under General, enter -2134 for Start Offset.

**Exercise 3: Adding Braces to the Structural Frame**

In this exercise, you add braces to the frame of the residence that span from the upper portion of the columns to the roof edge beam at 45 degree angles. You explore some of the different methods that you can use to add the braces.

To more easily add the braces to the frame, you use the Isolate Objects command to display temporary elevation views of the front and back of the frame model. These views, like the one shown above, include only the objects that you need to work with: the front columns, the floor edge beams, and the roof edge beams. After you add braces in one of the temporary elevation views, you close the view and redisplay the model.

**Display a temporary front elevation view of the frame**
1 With the Project Navigator open, click the Constructs tab.
2 Under the Constructs folder, double-click X-House Structure to open it in the drawing area.
   The construct contains an isometric view of the steel frame. You want to begin this exercise by adding braces to the front of the frame. You cannot easily add them in the current view.
3 Select the objects that you would include in a front elevation of the frame: the columns, the floor edge beam, and the roof edge beam. You do not need to select the footings under the columns.

4 With the columns and beams selected, right-click, and click Isolate Objects ➤ Edit in Elevation.

5 Select the front face of one of the columns to specify the elevation view direction.

An elevation view of the front columns and the roof edge beam is displayed, accompanied by an Edit in View toolbar. You use the toolbar button to return to the isometric view of the complete frame later in the exercise, after you add the braces.

6 Click on the Zoom flyout on the Navigation toolbar to zoom the extents of the drawing.
Click on the Shading toolbar to display a wireframe view of the frame.

Add braces between the right side of each column and the roof edge beam.
On the drawing window status bar, turn off all drawing aids.

Right-click the tool palettes set title bar, and click Steel-Framed Residence_M.

On the Structural Member Styles palette, click Brace RHS30x30x2.6. Confirm it is a Brace and not a beam or column.
If you needed to make a change you can do so in the tool properties.

On the Properties palette, specify the brace properties and the method you want to use to add braces to the frame:

- On the Properties palette, under Dimensions, select Middle Left for Justify.
- Under Rise, select No for Specify rise on screen to set the rise in the Properties palette before you add the braces. The rise is the vertical distance between the start point and the endpoint of the braces.
- Select Angle for Method to add the braces between the columns and beam at an angle.
- Enter 1220 for Distance along first member to specify the start point of the braces 1220 along the column from the point at which the column and roof beam connect. First member refers to the first member you select. In this case, the column, will be the first member that you select when you add a brace.
- Enter 45 for Angle from first member to add the braces from the columns to the roof edge beam at a 45 degree angle.

Select the first column on the left of the frame, move your cursor up and to the right, and select the roof edge beam.
A brace is added between the column and the beam at a 45 degree angle. The brace is middle left justified, and is placed 1220 along the column from the point at which the column and roof edge beam connect.

Add three additional braces between the three remaining columns and the roof edge beam.

Add braces between the left side of each column and the roof edge beam.
On the Structural Member Styles palette, click Brace RHS30x30x2.6, and specify another method of adding the braces to the frame:

- On the Properties palette, under Dimensions, select Middle Right for Justify.
- Under Rise, select Distance for Method.
- Enter 1220 for Distance along first member to specify the start point of the braces 1220 along the column from the point at which the column and roof edge beam connect. First member refers to the column, which is the first member that you select when you add a brace.
- Enter 1000 for Distance along second member to position the endpoint of the brace 1000 along the roof edge beam from the point at which the column and roof edge beam connect. Second member refers to the roof beam, which is the second member that you select when you add a brace.
15 Select the first column on the left of the frame, move your cursor up and to the left, and select the roof edge beam.

16 Add three additional braces between the three remaining columns and the roof edge beam.

17 Add a diagonal brace between two columns
   On the Structural Member Styles palette, click Brace RHS30x30x2.6.
18 On the Properties palette, under Rise, select Yes for Specify rise on screen.
19 On the command line, enter node for Start point, and select the first column on the left above the floor slab.
20 Enter from.
21 Enter node for Basepoint, and select the column on the right above the floor slab.
22 With your cursor pointing up for the node, enter 900 for Offset, and press ENTER.
   A brace is added between the two columns.

23 Delete the brace that you just created.
24 Close the temporary view and view the member justification

   On the Edit in View toolbar, click 

25 Click on the Zoom flyout on the Navigation toolbar to zoom the extents of the drawing.
26 Click on the Views flyout on the Navigation toolbar to display the top view of the frame.
27 Click on the Shading toolbar to display a wireframe view of the frame.
   You can view the justifications of the structural members in this view.
28 Add braces to the back of the frame

   Click on the Views flyout on the Navigation toolbar to display the back of the frame.
29 Select the columns, the floor edge beam, and the roof edge beam to include in the back elevation view of the frame.
30 With the columns and beams selected, right-click, and click Isolate Objects ➤ Edit in Elevation.
31 Select the back face of one of the columns to specify the elevation view direction.
32 In the back elevation view, click on the Shading toolbar to display a wireframe view of the frame.

33 On the Structural Member Styles palette, click Brace RHS30x30x2.6, and specify the distance method that you used previously to add the braces to the front of the frame:

- On the Properties palette, under Dimensions, select Middle Left for the braces that you place on the right and Middle Right for the braces that you place on the left.
- Under Rise, select Distance for Method.
- Enter 1220 for Distance along first member to specify the start point of the braces 1220 along the column from the point at which the column and roof edge beam connect.
- Enter 1000 for Distance along second member to position the endpoint of the brace 1000 along the roof edge beam from the point at which the column and roof edge beam connect.

34 Add the same eight braces to the back of the frame that you added to the front of the frame.

35 On the Edit in View toolbar, click to close the temporary view and display the braced frame.

Exercise 4: Creating Roof, Ceiling, and Floor Slabs

In this exercise, you create roof, ceiling, and floor slabs for the steel-framed residence. You create the slabs above and below the glass skin of the residence, which is provided in the dataset. After you create the slabs, you apply materials to them to differentiate between the three slab types, making them look more realistic. You also change the materials of the upper and lower glazing members that compose the residence skin.

You create the slabs from a closed rectangular polyline that represents the geometry of the slabs. It is placed in the drawing at the height at which you want to create the floor slab. When you create the roof and ceiling slabs, you project them to the appropriate heights above the outline, and assign them each a thickness. You retain the outline in the drawing after you create the roof and ceiling slabs, and then convert it directly to the floor slab.
To apply materials to the slabs and glazing members, you use the standard Material tool on the Design palette to assign material definitions. A material definition is a set of display settings that depict a real-world material. To apply a material to an object, you assign a material definition to applicable display components in the style of an object. When you assign a material definition in an object style, the material is applied to all objects in the drawing that share that style, like the slabs that you create in this exercise. You learn how to change, or "override," the material definition that has been assigned to an object by its style to assign a unique material to the individual object.

You complete the exercise by creating a palette of project-specific material tools. Projects standards have been applied to this project, and the project contains a project-specific tool group named Steel-Framed Residence_M. When you begin the exercise, this tool group contains only a single palette, Structural Member Styles. You add a Materials palette that contains the new materials that you apply in the exercise.

Create roof and ceiling slabs
1. With the Project Navigator open, click the Constructs tab.
2. Under the Constructs folder, double-click X-House Skin to open it in the drawing area.
   The drawing contains the residence skin, which is composed of beams, columns, and a glazing material. A rectangular polyline outline is displayed under the skin. You will use this outline to create roof, ceiling, and floor slabs for the residence.
3. Right-click the tool palettes set title bar, and click Design.
4. On the Design palette, right-click Slab, and click Apply Tool Properties to ➤ Linework and Walls.
5. In the drawing area, select the rectangular slab outline, and press ENTER.
6. Press ENTER to retain the layout geometry.
   You need to retain the outline to create the other two slabs later in the exercise.
7. Press ENTER for Creation Mode to project the creation of the slab at a height above the polyline.
8. Enter 3315 to specify the base height, or the height above the polyline where you want to create the slab.
9. Press ENTER to align the bottom of the slab at the base height.
10. With the slab selected, on the Properties palette, under Dimensions, enter a thickness of 100.
11. Press ESC.
12. Repeat the same steps to create a ceiling slab, but enter a base height of 2895 and a thickness of 17.
13 Create a floor slab
   On the Design palette, right-click Slab, and click Apply Tool Properties to ➤ Linework and Walls.
14 In the drawing area, select the rectangular slab outline, and press ENTER.
15 Enter y (Yes) to erase layout geometry, and press ENTER.
16 Enter d (Direct) for Creation Mode to create the slab directly on the layout geometry.
17 Enter t (Top) to align the top of the slab with the polyline.
18 With the slab selected, on the Properties palette, under Dimensions, enter 30 for Thickness.
19 Press ESC.
20 Apply a material to the floor slab
   On the Design palette, click Material, and select the floor slab.
21 On the Apply Material to Components worksheet, under Select component(s) to apply the material, select Finishes.Flooring.Stone.Pavers.Terra Cotta.
22 Under Apply to, select Style, and click OK.
   The terra cotta pavers are applied to all three slabs because they share the Standard style. You have decided that you do not want to use the terra cotta pavers on the floors. You now want to change the floor material to a white marble, without applying it to the ceiling and roof.

23 On the Design palette, click Material, and select the floor slab.
24 On the Apply Material to Components worksheet, under Select component(s) to apply the material, select Finishes.Flooring.Stone.Marble.White.
25 Under Apply to, select Object Override, and click OK.
   The marble flooring is applied to only to the floor slab.
26 Apply a material to the ceiling and roof slabs
   On the Design palette, click Material, and select the ceiling slab.

27 On the Apply Material to Components worksheet, under Select component(s) to apply the material, select

28 Under Apply to, select Object Override, and click OK.

29 On the Design palette, click Material, and select the roof slab.

30 On the Apply Material to Components worksheet, under Select component(s) to apply the material, select Site

31 Under Apply to, select Object Override, and click OK.

32 Apply an ash material to the lower glazing members
   Click on the Zoom flyout on the Navigation toolbar, and zoom in to the area around the front corner of
   residence.
33 Apply the Wood.Finish Carpentry.Wood.Ash material to the Sill Glazing component of one of the lower glazing members and specify a style override.

The lower glazing members share the same object type and style, so you only need to apply material to the style of the individual member to apply it to all of the others.

34 Update the project standards with the new material definitions
On the File menu, click Save to save the drawing with its new material definitions.

35 In the Style Manager, select Material Definitions, right-click, and click Update Standards from Drawing.
   The Update Project Standards worksheet is displayed. The definitions of the new material tools are listed in the lower half of the worksheet.

36 Under Action, verify Add to Project Standards is selected for each material definition, and click OK.

37 In the Style Manager, click OK.

38 Click Yes to update the project standards drawing with the new material definitions.

   The material definitions are added to the project standards drawing, Styles_STD.dwg, which is stored in the project structure. The tools in the Steel-Framed Residence_M tool group reference this drawing for their styles and definitions.

39 Create material tools
   Right-click the tool palettes set title bar, and click New Palette.

40 Enter Materials for the palette name.

41 On the Format menu, click Style Manager.

42 In the left pane of the Style Manager, expand STL101-Steel-Framed Residence_M, expand Styles_STD.dwg, expand Multi-Purpose Objects, and expand Material Definitions.
   The material definitions that you have applied to objects and saved as standard materials are listed.
   Drag the material definitions that you applied to the slabs and the ash material that you applied to the glazing to the Materials palette.
   New material tools are displayed on the palette.

43 Apply the ash material to the upper glazing members
   Select the roof and ceiling slabs, click on the drawing window status bar, and click Hide objects.

44 Click on the Zoom flyout on the Navigation toolbar, and zoom in to an area around one of the upper glazing members.

45 On the Materials tool palette, click the Ash tool.

46 Select one of the upper glazing members, and apply the Wood.Finish Carpentry.Wood.Ash material to the Header Glazing component of all the upper glazing members by specifying a style.
The upper and lower glazing members all have an ash material applied to them.

47 To redisplay the roof and ceiling slabs, click on the drawing window status bar, and click End Object Isolation.

48 On the File menu, click Save to save the materials change to the upper glazing members.
   The new Materials tool palette is now part of the project tool group and will be available if you open another project drawing.

**Lesson 2: Creating a Roof Enclosure and a Screen**

In this lesson, you create roof slabs from a roof object and create structural members by edge and by fill to create the framing members of a roof. You trim the structural members by edge and by face.
Exercise 1: Creating Structural Members from a Roof Slab

In this exercise, you create structural members on a roof slab.

**Convert a roof to roof slabs**

1. With the Project Navigator open, click the Constructs tab.
2. Under the Elements folder, double-click X-Structure from Slab.
   The drawing contains a roof.

3. Click on the Shading toolbar to display a wireframe view of the roof.

4. Select the roof, right-click, and select Convert to Roof Slabs.

   **TIP:** The roof was created to control properties for the slope. You convert this roof to roof slabs, because roof slabs are objects on which you can create an array of structural members.

5. On the Convert to Roof Slabs worksheet, select Erase Layout Geometry, and click OK.
   The roof is deleted and four roof slabs are created with the generic Standard slab style. Each slab displays its own set of grips.

6. Press ESC to deselect the slabs.

7. Select the back slab and the two side slabs, click on the drawing window status bar, and click Hide Objects.

8. Create a structural member along the edge of the roof slab
   Right-click the tool palettes set title bar, and click Steel-Framed Residence_M.
9 On the Structural Member Styles palette, click 50x100.
10 On the Properties palette, specify the edge option and the beam justification:
   ■ Under Dimensions, select Edge for Layout type.
   ■ Select Bottom Left for Justify.
11 On the application status bar, if the OSNAP button is selected, click it to turn off all Osnap settings.
12 Move your cursor over the roof edge, and when the beam displays along the inside of the roof edge, click to place it.

13 **TIP:** Justification depends on the direction in which objects are drawn. The goal here is to create the structural member on the inside of the roof slab.

---

14 Press ESC.
15 Create hip and ridge members
   On the Structural Member Styles palette, click 50x300.
16 On the Properties palette, specify the member properties:
   ■ Under Dimensions, select Edge for Layout Type.
   ■ Select Bottom Center for Justify.
17 With Osnaps off, use the select option to Add beam to the three remaining single edges.
18 Press ESC to exit the command.
19 Create an array of structural members that are aligned with the slab
   On the Structural Member Styles palette, click 50x200.
20 On the Properties palette, specify the member properties:
   ■ Under Dimensions, select Fill for Layout type.
   ■ Under Layout, select Yes for Array.
   ■ Select Repeat for Layout method.
   ■ Enter 600 for Bay size.
21 Click on the Zoom flyout on the Navigation toolbar, and zoom to the area around the slab bottom.
22 Select the midpoint of the slab to add an array of beams relative to the roof slab.
23 Press ESC.

24 Press ENTER to repeat the command and place some members as bracing using a node snap and clicking near the midpoint of each rafter.

25 Press ESC.

**TIP:** Because you can define properties in a tool, you could copy the member tool (right-click on tool and copy, then paste) and make an array member tool with tool properties such as the specified bay size.

26 Erase the roof slab that you used to create the structural members.

27 To redisplay the back and side roof slabs, click on the drawing window status bar, and click End Object Isolation.

28 Click Save to save the drawing.

**Exercise 2: Trimming Structural Members**

In this exercise, you select structural members and use the context menu to add trim planes to the members. Structural members can be trimmed on the object line (justification), by selecting two points or trimmed to a face. You trim to the object line and to the face.

**Trim the internal frame members**

1. Click on the Views flyout on the Navigation toolbar to display the top view of roof.
2. Hide the short arrayed beams.
3. Select all the beams that connect to the ridge beam.

4. With the beams selected, right-click, and click Trim Planes ➤ Add Trim Plane.
5. On the application status bar, turn off OSNAP.
6. Select the ridge line at the top of your screen.
7. Press ESC to exit the command.
8. Select any one of the arrayed beams, right-click, and click Select Similar.
   All of the beams with similar styles are selected.
9. With the beams selected, right-click, and click Trim Planes ➤ Add Trim Plane.
10. Select the bottom member.
11 Click on the Zoom flyout on the Navigation toolbar, and zoom in around side of the roof.

12 Select the beams that meet the hip member.

13 With the beams selected, right-click, and select Trim Planes ➤ Add Trim Plane.

14 Select the diagonal hip member.

**TIP:** The Structural display configuration from the Structural template represents the members as single lines and facilitates selection for trimming.

15 Repeat steps 9-13 for the remaining members that intersect with the other hip member.

16 Extend the ridge while offsetting the start or end
   
   Click on the Views flyout on the Navigation toolbar.

17 Click on the Zoom flyout on the Navigation toolbar, and zoom in around the connection between ridge and hip members.

18 Select the ridge member.

19 Click the inside arrow, drag your cursor to the left, and enter 300 to offset the ridge line from its end.

20 Press ESC.

21 Trim to the face of the ridge beam
   
   Select the hip member.
   
   Trimming always begins by selecting the member or members to trim.

22 With the hip member selected, right-click, and click Trim Planes ➤ Add Trim Plane.

23 Move your cursor over the ridge member, and press CTRL to toggle to the Trim to Face option.

24 Move the cursor over the tall face of the ridge member, and when it highlights and displays a hatch pattern, click to select the face.
25  Right-click on the 50x200 tool and select Apply Tool Properties to Beam and pick the hip member.
26  Repeat steps 20-24 for the other hip member.

NOTE: The Osnaps are off.

Additional members can be created on the other slabs if you end object isolation or where there is symmetry they can be mirrored. The same techniques that you used on this one slab can be repeated to create a finished roof structure.

27  Click Save to save the drawing.

Exercise 3: Create an Array of Structural Members for a Screen

In this exercise, you create a louvered screen between two of the columns of the structural frame of the reference.

You create the initial design of the screen by using the Fill and Array layout options to add standard style beams between the two columns.

To complete the louvered screen, you assign new styles and roll values to selected louvers. When the louvers are complete, you change the element drawing in which you create them to a construct. You assign the construct to the House floor level in both residence design options.
Open the louver screen element drawing

1. With the Project Navigator open, click the Constructs tab.
2. Under the Elements folder, double-click X-Louver Screen.

The drawing contains the eight columns referenced from the house structure. The element drawing itself is empty.

3. Create a generic array of beams

   Click on the Zoom flyout on the Navigation toolbar, and zoom in around the two front-right columns.

4. Right-click the tool palettes set title bar, and click Design.
5. On the Design palette, click Structural Beam.
6. On the Properties palette, specify the beam properties:
   - Under Dimensions, enter 0 for Roll.
   - Select Fill for Layout type.
   - Under Layout, select Yes for Array.
   - Select Repeat for Layout method.
   - Enter 600 for Bay size.

7. Using a node snap, click on the top of each column.

   The array of beams is created between the column start and endpoints. The bottom of each column has a start offset downward to the footing leaving the actual start point of the columns at floor level where it connects with the floor edge beam. The array is added between the start and endpoints of the columns.
Lesson 3: Sharing Design Data

In this lesson, you explore different ways of communicating the design of the steel-framed residence. You learn different techniques that you can use to share design data with others.

You begin by creating a terrain model that represents the site where residence will be built. After the terrain model is complete, you create a new view drawing that references the terrain model, a view of the residence and deck, and the site’s water table. You export this view to VIZ Render, the 3D visualization application that is installed with Architectural Desktop, where you create an animation that depicts the effects of potential flooding on the residence.
You then learn how to create elevation and section views of the residence from the constructs that create the building model. You create sheets, on which you place the views. You can distribute these sheets either by printing or electronically publishing them.

At the end of this lesson, you publish 3D model and detail views of the structural frame to 3D DWF™ files. DWF files, or Design Web Format files, are the Autodesk method of publishing 2D or 3D design data to the Internet or to an intranet. With 3D DWF Publishing, you can generate DWF files of your three-dimensional models with nearly the same visual fidelity as your original DWG files. You can view DWF files with a web browser, like Microsoft® Internet Explorer, or with the free downloadable Autodesk® DWF™ Viewer, from where you can also plot the file. Publishing a model to 3D DWF allows you to share the model with consultants, clients, or construction teams, who traditionally receive only 2D plans.

Exercise 1: Creating a Terrain Model

In this exercise, you learn how to create a terrain model that represents the steel-framed house site. The terrain model is a Free Form mass element that approximates the varying terrain of the site.
You begin with a site plan that contains sketched polyline contours. The contours are assigned elevations to depict the topographical features of the site, such as a hill and a pond.

To create the terrain model, you use the Drape tool on the Massing palette. You select the elevated contour lines, and then use the tool to "drape" a Free-Form mass element over the contours. To control the accuracy of the model, you specify how many sections (subdivisions) are used to calculate the surface of the model, the mesh. To define the extents of the terrain model, you specify a rectangular boundary, or define the model extents from the contours that bound the site. You also specify the depth that the model should extend below the lowest point of the selected contours.

Create a mass element that represents the site terrain

1. With the Project Navigator open, click the Constructs tab.
2. Under the Elements folder, double-click X-Terrain to open it in the drawing area.

The sketched and elevated contour lines that represent the topography of the site are displayed in two drawing viewports. The left viewport contains a plan view of the contour lines, and the right viewport, an isometric view. In the right viewport, you can see the depth of the pond (the depression) that is on the site.
3 In the left viewport, click on the Zoom flyout on the Navigation toolbar to zoom the extents of the drawing.
4 Right-click the tool palettes set title bar, and click Design.
5 On the Massing palette, click Drape.
6 Select all the contour lines in the drawing, and press ENTER.
7 Press ENTER to retain the contour lines in the drawing.
8 Press ENTER to generate a regular mesh.
9 Use a crossing window to select a rectangular portion of terrain that includes the pond and hill.
   This rectangle specifies the boundaries within which the terrain model will be created.

10 Press ENTER twice to except the default XY mesh subdivisions.
11 Enter 3000 for base thickness, and press ENTER.
12 In the right viewport, click on the Shading toolbar to flat shade the terrain model.
13 Click on the Shading toolbar to Gouraud shade the terrain model.
14 You can view the depth of the depression and the elevation of the hill.

15 In the right viewport, select and delete the terrain model.

16 Create a more detailed terrain model
   In the left viewport, on the Massing palette, click Drape, and recreate the terrain model:
   - Select all the contour lines, and press ENTER.
   - Press ENTER to retain the contour lines in the drawing.
   - Press ENTER to generate a regular mesh.
   - Use a crossing window to select a rectangular portion of terrain that includes the depression and hill, and press ENTER.
   - Enter 100 for Mesh subdivision along X direction.
   - Enter 100 for Mesh subdivision along Y direction, and press ENTER.
   - Enter 6000 for base thickness, and press ENTER.
   - In the right viewport, view the terrain model.

17 The terrain model has a thicker base and is more articulated than the previous model, resulting from the larger base thickness and meshing values that you specified. The larger meshing values yielded a finer mesh.

18 In the right viewport, select and delete the terrain model.

19 Deepen the pond and elevate the crest of the hill
   On the command line, enter point, and press ENTER.

20 In the left viewport, specify a point in the middle of the circular contour line that represents the deepest part of the depression.

21 Select the point, and on the Properties palette, under Geometry, enter -5000 for Position Z.

22 On the command line, enter line.

23 Draw a line across the hill below the depression.
Select the line, and on the Properties palette, under Geometry, enter 300 for Start Z.

Enter 900 for End Z.

Press ESC to clear the line selection.

Create a terrain model that features the new pond depth and hill crest

In the left viewport, on the Massing palette, click Drape, and recreate the terrain model:

- Select the contour lines, the point, and the hill crest line and press ENTER.
- Press ENTER to retain the contour lines in the drawing.
- Press ENTER to generate a regular mesh.
- Use a crossing window to select a rectangular portion of terrain that includes the depression and hill, and press ENTER.
- Enter 100 for Mesh subdivision along X direction.
- Enter 100 for Mesh subdivision along Y direction, and press ENTER.
- Enter 6000 for base thickness, and press ENTER.
- In the right viewport, view the terrain model.

The terrain model looks like the previous one that you created, only now the pond is noticeably deeper and the hill has a pronounced crest.

In the right viewport, delete the terrain model.

On the command line, enter dispsilh (Display Silhouette Edges).

Enter a value of 0.

In the left viewport, on the Massing palette, click Drape, and recreate the terrain model:

- Select the contour lines, the point, and the hill crest line, and press ENTER.
- Press ENTER to retain the contour lines in the drawing.
- Press ENTER to generate a regular mesh.
- Use a crossing window to select a rectangular portion of terrain that includes the depression and hill, and press ENTER.
- Enter 30 for Mesh subdivision along X direction.
- Enter 30 for Mesh subdivision along Y direction, and press ENTER.
- Enter 6000 for base thickness, and press ENTER.
32 In the right viewport, click on the Shading toolbar to view the terrain model in a wireframe view. The mesh that is "draped" over the site to create the terrain is visible.

33 Click on the Shading toolbar to Gouraud shade the terrain model.

34 In the right viewport, select and delete the terrain model.

35 Create a terrain model with finer meshing
   With the left viewport current, on the Massing palette, click Drape, and recreate the terrain model:
   ■ Select the contour lines, the point, and the hill crest line, and press ENTER.
   ■ Press ENTER to retain the contour lines in the drawing.
Press ENTER to generate a regular mesh.
Use a crossing window to select a rectangular portion of terrain that includes the depression and hill, and press ENTER.
Enter 100 for Mesh subdivision along X direction.
Enter 100 for Mesh subdivision along Y direction, and press ENTER.
Enter 6000 for base thickness, and press ENTER.

36 In the right viewport, click on the Shading toolbar to view the terrain model in a wireframe view.
The terrain model mesh is finer than the mesh created in the previous model, because you specified larger meshing values for this terrain model.

37 In the left viewport, click on the Zoom flyout on the Navigation toolbar, and zoom in to an area around the pond.

38 In the right viewport, select and delete terrain model.
39 Create a site-shaped terrain model
   On the command line, enter dispsilh (Display Silhouette Edges).
40 Enter a value of 1.
41 In the left viewport current, on the Massing palette, click Drape, and recreate the terrain model:
   Select all the contour lines, the point, and the hill crest line, and press ENTER.
   Enter y to erase the selected contours.
Enter *n* to generate a non-regular mesh.
- Enter *n* to generate a non-rectangular mesh.
- Enter **6000** for base thickness, and press ENTER.

42 In the right viewport, click ⌁ on the Zoom flyout on the Navigation toolbar to zoom the extents of the drawing.

43 Click ☰ on the Shading toolbar to Gouraud shade the terrain model.

By specifying a non-regular and non-rectangular mesh, the extents of the contour lines were used to form the boundary for the terrain model. The resulting terrain model is shaped like the site.

**Exercise 2: Analyzing the Site for Flooding**

In this exercise, you analyze the flooding effect that a rise in the water table would have on the residence site. You begin by creating a new view drawing that includes the structure of the house and one of the deck design options. The view drawing references a construct and an element. The construct contains the terrain model that you created in the previous exercise and the element contains a 3D solid that represents the water table.

After the view drawing is complete, you export the model in the view drawing to VIZ Render. When you export the Architectural Desktop model, you actively link it to VIZ Render. You learn how you can maintain and use the link to update the VIZ Render scene with changes that you make to the Architectural Desktop model.

After you update the VIZ Render scene, you render it, and then create an animation that depicts the water table rising and flooding the site. You could use the completed animation to convey the potential hazard of building on the site to a client or builder.
Create a new view of the model
1 With the Project Navigator open, click the Views tab.
2 Right-click the Model folder, and click New View Dwg ➤ General.
3 On the Add General View worksheet, enter **Model** for Name, and click Next.

4 Under Division, select House Floor and Deck for Option 1, and click Next.

5 Clear Constructs, and select Deck 01 and House Structure, and click Finish.
6 In the Views tree, double-click Model.

7 On the application status bar, click GRID to turn off the drawing grid.
   A top view of the residence frame and deck is displayed.

8 Reference the terrain model in the Model view
   On the Project Navigator, click the Constructs tab.

9 Under the Constructs folder, select Terrain, and drag it to the drawing area.
   An external reference to the Terrain construct is added to the view, and you can see the terrain model in the
drawing.

10 Click ** on the Views flyout on the Navigation toolbar.

11 Click ** on the Zoom flyout on the Navigation toolbar to zoom the extents of the drawing.

12 On the File menu, click Save.

13 Export the model to VIZ Render
   On the drawing window status bar, click **, and click Link to VIZ Render.
   VIZ Render opens automatically, and displays the model that you exported from Architectural Desktop.
14 If the File Link Settings dialog displays, click OK.

15 In VIZ Render, on the Viewport Navigation toolbar, click , and zoom in closer to the model.

16 Minimize VIZ Render.

17 Reference the water table element in the Model view
   In Architectural Desktop, on the Project Navigator, click the Constructs tab.

18 Under Elements, select Water.

19 In the bottom pane of the Project Navigator, click .
   A preview of the Water element is displayed. The element contains a 3D solid which represents the site’s water table.

20 Select Water, and drag it to the drawing area.

21 Click on the Shading toolbar to flat shade the terrain model and view the effect of the water table on the site.

22 Render the scene in VIZ Render
   Maximize VIZ Render.

23 On the File Link toolbar, click .
   The VIZ Render scene is updated with the water table that you added in the Architectural Desktop view.
24 On the Viewport Navigation toolbar, click 
, and zoom out so you can view the entire site.

25 On the Rendering menu, click Render.

26 At the bottom of the Render Scene dialog, select Draft in the Preset list.

27 Click Load in the Select Preset Categories dialog, and click Render in the Render Scene dialog. The completed rendering is displayed in a separate window.

28 In the Rendering window, click 
.

29 In the Browse Images for Output dialog, browse to c:\my documents\autodesk\my projects\steel-framed residence_M\supplemental, and save the file as a BMP file.

30 Create an animation that shows the site flooding caused by the rising water table

   In VIZ Render, on the Viewport Navigation toolbar, click 
, and zoom out to view the entire scene.

31 On the bottom right corner of the VIZ Render window, click 
.

32 In the Time Configuration dialog, under Animation, enter 300 for Length, and click OK.

33 On the Selection toolbar, click 
, and select the water table in the scene.

34 On the bottom of the VIZ Render window, click Animate to reposition the water table object in the scene over a period of time.

   The time slider at the bottom of the screen is highlighted in red.

35 Drag the time slider across the bottom of the window, until 300/300 is displayed.

36 In the scene, right-click, and select Move from the quad menu.

   The transform gizmo is displayed on the water table.

37 Select the Z axis of the transform gizmo, and move your cursor up, until the water table visibly floods the site.

   A field displays a Z Value. The house floor is at an elevation of 0 and the anticipated 100-year flood is at -600 mm. To precisely depict the flooding, you can enter the flood value in the Z field.
38 Drag the time slider across the bottom of the window, until 0/300 is displayed.
39 Drag the time slider across the bottom of the until 300/300 is displayed. The water table should rise as you drag the time slider.
40 Drag the time slider back to 0/300 to finish positioning the water table, and click onscreen to exit selection mode.
41 Click Animate.
42 On the Rendering menu, click Render.
43 In the Render Scene dialog, click the Environment tab.
44 In the Background rollout, select a white Background Color.
45 In the Exposure Control rollout, select Logarithmic Exposure Control.
46 Click the Common tab.
47 In the Common Parameter rollout, select Active Time Segment.
48 Under Output Size, click 800x600.
49 In the Render Output rollout, click Files.
50 In the Render Output dialog, browse to c:\my documents\autodesk\my projects\steel-framed residence\supplemental, and save the file as Flooding and the type as AVI.
51 In the AVI File Compression Setup dialog, click OK.
52 In the Render Scene dialog, click Render. The animation takes a few minutes to render.
53 Use Windows Explorer to locate and play the flooding animation to view the effects of the flooding. You can use any player that you have installed on your system that can play AVI files. This lets you easily share your animation with others who do not have VIZ Render installed.

**NOTE:** You can play the animation within VIZ Render. On the Rendering menu, click Render. In the Render Scene dialog, on the Common panel, click Files on the Render Output rollout. In the Render Output File dialog, browse to select the AVI, and click View.
To learn how to create realistic animations that include materials and lighting, see the VIZ Render tutorials. You can access the tutorials from the Help menu in VIZ Render.

**Exercise 3: Creating Elevations for a Sheet**

In this exercise, you create a view drawing for exterior elevations with title marks, and then you place the elevations on a sheet.

Create a view drawing for sections or elevations
1. With the Project Navigator open, click the Views tab.
2. Under the CD Set folder, right-click Elevations, and click New View Dwg ➤ Section/Elevation.
3. On the Add Section/Elevation View worksheet, enter X-House Option 01 for Name, and click Next.
4 Under Division, select 01 for all three levels, and click Next.

5 Clear any of the constructs that you do not want referenced to the view drawing (in this case, any exercise file prefixed with an X).

**NOTE:** The list includes constructs that were assigned to Option 01 when they were created. Construct properties, including the assignment to a location (level/division), can be left blank or re-assigned at any time. It is this automatic listing of potential external references for a view that is affected by level/division assignment.
6 Click Finish.
   The drawing has now been created with external references.
7 In the Views tree, double-click X-House Option 01 to open the drawing.

8 Use a callout tool to create all four exterior elevations
   Right-click the tool palettes set title bar, and click Document.

9 On the Callouts tab of the Document tool palettes group, click Exterior Elevation Mark A3
10 Click diagonally opposite corners of an area enclosing the model.
11 On the Place Callout worksheet, select the New Model Space View Name field, and change the default names to North, East, South, and West.
   Duplicate names for model spaces are not allowed, so if a name is already in use in the project, it will be assigned an incremented number to make it unique.
12 Select Generate Section/Elevation and Place Titlemark.
13 For Scale, select 1:100.
   This value controls the correct sizing of the titlemark.
14 Click Current Drawing.
   The callout symbols are displayed on all four sides of the model.

In the drawing window, specify an insertion point for the 2D elevation, and then specify a second point to establish the spacing and direction.

The two points that you specify define the distance between the model space views on the sheet and the direction for model space view creation. Named model space views are created for each elevation object and are listed under the view drawing in the Views tree in the Project Navigator.

15 Save the drawing before creating the sheet. Views with added model space views must be saved before the views are available for use in a sheet.
17 On the Project Navigator, click the Sheets tab.
18 In the Sheet Set View tree, under Architectural, right-click Elevations, and click New ➤ Sheet.
19 On the New Sheet worksheet, enter 103 for Number and Elevations for Sheet title.

![New Sheet dialog box]

**TIP:** Unlike other templates, the sheet template is defined in the properties of the sheet set. To review sheet defaults, right-click the root node of the Sheet Set View tree, and click Properties.

20 Click OK to create the elevations sheet.
21 In the Sheet Set View tree, double-click A-103 Elevations to open the sheet.

**TIP:** A padlock on the sheet icon in the tree indicates that it is open. Refresh the project to see the current settings.

22 With the sheet open, click the Views tab on the Project Navigator.
23 Expand the X-House Option 01 drawing in the tree. The four elevation views you generated are displayed under the view drawing.
24 Select the North model space view, and drag it onto the sheet.
   Since the elevations were created with a correctly scaled title mark, you can insert them as they are without having to right-click and change the scale. If you plan to create annotation only on the sheet and are uncertain of the finished scale for views on the sheet, then you would create the model space views without annotation and have the option of changing the scale as you place the views.
25 Repeat step 24 for the West, East, and South elevation views.

**TIP:** You can rearrange the individual elevation sheet views on the sheet if necessary. Use OTRACK to help place the views precisely.

26 Optionally, you can repeat the steps in this exercise for X-House Option 2, in which other constructs are assigned.

**Exercise 4: Updating Elevations**

In this exercise, you identify the view drawing as a collection of external references. You unload unwanted external references—Screening 01 (screening curtains for privacy) and Glass Skin 01—and update the elevations so that the building interior is revealed for the elevations in the view and on the sheet.
Unload external references in the view drawing

1. With the Project Navigator open, click the Views tab, and expand the Elevations category.
2. Double-click X-House Option 01 to open it in the drawing area.
3. At the far right of the drawing window status bar, click the Manage Xrefs button.
4. On the Xref Manager worksheet, select Glass Skin 01, and click Unload. (This keeps the external reference attached but hidden.)
5. Select Screening 01, and click Unload.
6. Click OK.
7. In the X-House Option 01 drawing, select all four elevations.
8. Right-click, and click Refresh to update the elevations as shown.

NOTE: The Refresh option is only available where objects, in this case xrefs, that were used for the elevations have been removed from the original list of objects. If new objects are added, then the elevations would be regenerated.

10. On the Project Navigator, click the Sheets tab.
12. Click the notification that is displayed to reload the changed view drawing.

Exercise 5: Creating a Section for a Sheet

In this exercise, you update a view drawing for a section, annotate the model space view, and place title marks on the sheet.

1. With the Project Navigator open, click the Views tab.
2. Right-click the Sections folder, and click New View Dwg ➤ Section/Elevation.
3. On the Add Section/Elevation View worksheet, enter X-House Option 01 for Name, and click Next.
4 Under Division, select 01 for all three levels, and click Next.

5 Clear any of the constructs that you do not want referenced to the view drawing (in this case, any exercise file prefixed with an X), and assign it to Option 01.

**NOTE:** The list includes constructs that were assigned to Option 01 when they were created. Construct properties, including the assignment to a location (level/division), can be left blank or re-assigned at any time. It is this automatic listing of potential external references for a view that is affected by level/division assignment.
6 Click Finish.
   The drawing has now been created with external references.
7 In the Views tree, double-click X-House Option 01 to open it in the drawing area.

8 On the Project Navigator, click the Constructs tab.
9 Under the Constructs folder, select Terrain, and drag it to the drawing area.
   An external reference to the Terrain construct is added to the view, and you can see the Terrain model in the drawing.
10 If you cannot see both the building and the terrain in the drawing, on the Navigation toolbar, click the Regenerate Model button ( ), enter all, and press ENTER.

11 On the Callouts tab of the Document tool palettes group, click Section Mark A2T.
12 In the drawing area, specify four points to position the section mark as shown, and press ENTER.

13 Click in the drawing area above the model to specify the section extents, and press ENTER.
On the Place Callout worksheet, select the New Model Space View Name field, and change the default name to Deck and House Section.

Verify that Generate Section/Elevation is selected, Place Titlemark is not selected, and that the Scale is 1:100.

Click the Current Drawing button.

Specify an insertion point for the 2D section result to the right of the model.

Draw a crossing box to select the annotation and title mark under the 2D section, and press Delete. This allows you to right-click and select a scale when you place the section on a sheet.

Save the drawing before creating the sheet.

Views with added model space views must be saved before the views are available for use in a sheet.

Create a sheet

On the Project Navigator, click the Sheets tab, right-click the Sections node, and click New ➤ Sheet.

On the New Sheet worksheet, enter A-104 for Number and Building Sections for Sheet title.

Click OK to create the sections sheet.

On the Sheets tab of the Project Navigator, expand Sections, and double-click A-104 Building Sections.

Select Deck and House Section (a model space view), and drag it onto the sections sheet.

On the View tab of the Project Navigator, expand Sections, and drag the model view Deck House and Section onto the sections sheet.

Before you specify an insertion point on the sheet, right-click, and click 1:100 to change the scale.
27 When the 2D section is positioned and scaled as desired on the sheet, click the Callouts tab of the Document tool palettes group, and click Title Mark (with number).

28 Below the 2D section on the sheet, specify two points to insert the title mark.

29 Select the entire title mark and drag it onto the sheet view 1-Deck and House Section in the tree view on the Sheet tab.

The title mark is updated to show the view number and scale.

Exercise 6: Updating a Section

In this exercise, you update a view drawing for sections, add annotation at the correct size, and update the sheet.

1 With the Project Navigator open, click the Views tab.

2 Under Views\CD Set\Sections\X-House Option 01, double-click Deck and House Section to open the view and set the annotation scale.

3 On the Navigation toolbar, click to open the Content Browser.
This Content Browser icon accesses a library of all Architectural Desktop tools. It is different from the Content Browser icon on the Project Navigator, which accesses a library of project tools (in this case, the Steel-Framed Residence tools).

4 To find section tools to annotate the level of decks, enter section in the Search text box, and click GO.

5 When the search results are displayed, locate Elevation Label (2), and drag it into the drawing area as shown.

**TIP:** You can drag this tool onto the Annotation tool palette if you anticipate using it frequently.

6 Enter near (for nearest Osnap), press ENTER, and then click to display the Add Elevation Level worksheet.

7 On the Add Elevation Level worksheet, enter Finished Floor on Deck for Prefix, enter -600 for Elevation, and click OK to insert the annotation into the drawing.
8 Drag Elevation Label (2) from the Content Browser into the drawing again, and specify an insertion point at the edge of the house floor as shown.
The text is sized correctly for the active drawing scale.

9 On the Add Elevation Level worksheet, enter **Finished Floor - House** for Prefix, and click OK to insert the annotation into the drawing.

10 Close the Content Browser.

11 On the Shapes toolbar, click , specify two points to draw a line where the stepped section changes, and press ENTER.
Save the X-House Option 01 drawing with its correctly scaled annotation.

On the Sheets tab of the Project Navigator, under Sections\A-104 Building Sections, double-click the 1 Deck and House Section viewport.

When the External Reference File Has Changed message is displayed, click the link to update the sheet.

On the Views tree, right-click Deck and House Section, and click Properties.

**TIP:** If you have a detail drawing, each detail can have its own model space view. Clicking the model space view name sets the scale and locates the detail.
On the Modify Model Space View worksheet, double-click the Scale value to display the drop-down list of values you can select, then click OK. Do not change the scale.

**TIP:** Active scale only affects annotation you create it. Existing annotation does not resize when the active scale is changed.

Double-click the A-104 Building Sections sheet to open it in the drawing area.

On the Xref Manager worksheet, observe that the Terrain and X-House Option 01 xrefs are overlay attachments (from the sheet you are seeing only one level deep for external references), and then click OK.

On the Views tree, double-click the Deck and House Section model space view.

Reopen the Xref Manager, select Screening 01, and click the Unload button.

Click OK.

On the Standard toolbar, click to save the drawing, and then close it.

**NOTE:** This section is not up to date.

Update all sections and elevations in the entire project. On the Views tab, under Sections\House Option 01, double-click Building with Pond.

You can use any drawing in the project. Note that you unloaded the screening file for the Deck and House Section but did not update the section.

On the View menu, click Refresh Sections/Elevations.

On the Batch Refresh Sections/Elevations worksheet, select Current Project, and click Start.
When the Status pane indicates Done, click Close.

On the File menu, click Close.

Batch Refresh restores sections and elevations according to the selection set as it was at the time the section and elevation objects were created. The unloaded reference is reloaded. You might use this prior to plotting to ensure temporary changes (unload) do not affect the plotted drawings.

In the Views tree, double-click the Deck and House Section view.

Click the Sheets tab, and double-click the Deck and House Section sheet.

The sheet is up to date. Multiple sections and elevations are best updated in a view using Refresh, when there are no new external references. When there are new external reference, you use Regenerate so that you can add them to the list of objects used to create the section or elevation. Batch Refresh is intended as a check of status for the external references. The assumption behind Batch Refresh is that an Unload, for an external reference, was intended to be short-term. Batch Refresh reloads the external references and refreshes the sections and elevations. It is a task that might be initiated prior to plotting, with the assumption that you want unloaded external references to be reloaded.

Exercise 7: Publishing Model and Detail Views to 3D DWF

In this exercise, you publish a model view of the structural frame and a 3D roof detail to 3D DWF. After you publish each view, you view the 3D DWF files in the Autodesk DWF Viewer. The model is displayed in the right pane of the DWF Viewer, where you can change the viewing direction and shade the model. The left pane, or the Navigation pane, contains a tree view that lists the objects in your model.
When you publish to a 3D DWF file, you select an option to group the objects in your model. This determines how they will list in the Navigation pane in the DWF Viewer. You can group objects by external reference, object type, and style, or external reference, object type and layer. You can also opt not to group objects by external reference.

When publishing is complete, the objects in the drawing are hierarchically listed in the tree view in the Navigation pane according the grouping options that you specified. You can select items in the tree view to highlight or hide all the objects in the model of one type, all the objects of one type and style, and so on.

In this exercise, you group the objects in the 3D DWFS that you create by type and style, rather than type and layer. You group them in this way to allow finer selection control of the objects in the model. For example, the model contains structural members that have shapes that are set in their styles. By grouping them by type and style, you can select beams, braces, and columns individually or by style.

If you grouped the structural members by object type and layer, you would only be able to select individual beams, braces, and columns, or all beams, all braces, or all columns.

**Publish the frame model to a 3D DWF file**

1. With the Project Navigator open, click the Constructs tab.
2. Under the Constructs folder, double-click House Structure to open it in the drawing area.

   This construct contains the steel frame of the house that you completed in the previous exercise.
3 On the drawing window status bar, verify High Detail is displayed on the display configuration flyout.

4 On the File menu, click Publish to 3D DWF.

5 If you do not want to use the default location and name (the name of the drawing you are publishing) for the DWF, under DWF File Name, enter a different location and name.

6 On the AEC 3D DWF Publishing Options worksheet, under Group individual objects by, verify Object Type and Style are selected.

   Grouping structural members by object type and style gives you more selection control than layers would, particularly where you have different types of structural members (beams, braces, and columns) on the same layer. You do not need to select Group by Xref Hierarchy, because this drawing does not contain any external references.

7 Click OK.

8 In the drawing window, select the model to publish it to DWF, and press ENTER.

   A progress meter is displayed. When publishing is complete, you are asked if you want to view the DWF.

9 Click Yes.

   The Autodesk DWF Viewer is displayed. The 3D House Structure DWF is displayed in the right pane of the viewer. The object types in the drawing are listed in a tree structure in the left pane, the Navigation pane. A toolbar near the top of the viewer contains tools for printing and viewing DWF files.

10 On the toolbar, click the Standard Views flyout, and click Front Top Right.

   The residence structure is displayed in a different isometric view in the right pane of the viewer.
11 In the Navigation pane, expand Column Grid.
   The drawing only contains one column grid, as indicated by the number next to the object name. A column grid
does not have a style, so only the instance of the object is displayed under the object Column Grid name.

12 Select Column Grid.
   The column grid is highlighted in the view in the right pane.

13 Right-click Column Grid, and click Hide.
   In the Navigation pane, the column grid icon is displayed as white to indicate the column grid is hidden in the
   view in the right pane.
Expand Structural Member.
Expand one of the styles listed under Structural Member.
Because beams, braces, and columns are sub-objects of the structural member object type, and their types are set in their styles, you can view and hide the members by type (beams, braces, and columns) or by instance in the drawing.

Under Structural Members, select Beam Roof UB305x165x40.
All 13 of the roof beams are highlighted in the drawing.

Under Beam Roof UB305x165x40, select one of the roof beams.
The roof beam is highlighted in the model view in right pane.

With the same member selected, right-click and click Hide.
The member is hidden in the model view in the right pane. In the Navigation pane, notice the icon next to the member name in the tree view has changed from blue to white, to indicated that the member is hidden.
19 Close the viewer.

20 Publish a detail view to a 3D DWF file
   In Architectural Desktop, with the Project Navigator open, click the Views tab.

21 Under CD Set\Details, double-click Section Details.
   The view drawing contains three model space detail views. The details were created using industry standard 2D detail components and keynotes accessed from the Detail Manager.

22 On the Project Navigator, under Views\CD Set\Details, double-click 3D Details.
   A 3D detail is displayed that was created from one of the 2D details that you viewed previously. To create a 3D detail to publish to a 3D DWF, the 2D detail components in the 2D detail were converted to mass elements using the Convert to Mass Element Tool.

23 On the File menu, click Publish to 3D DWF.

24 On the AEC 3D DWF Publishing Options worksheet, under Group individual objects by, verify Object Type and Style are selected.
   Like the structural members that you published to DWF in the previous steps, you will have more selection control over the mass elements if you group them by object type and style, rather than layer.
25 Select only the top components of the detail to publish it to DWF, and press ENTER.

A progress meter is displayed. When publishing is complete, you are asked if you want to view the DWF.

26 Click Yes.

The Autodesk DWF Viewer is displayed. The 3D Detail DWF is displayed in the right pane of the viewer.

27 In the Navigation pane, expand Mass Elements to display the detail components at the style level.

The style names of the detail components are listed. To easily identify them in the model view, you can select them in the list, causing them to highlight in the model view. You can also select a detail component in the model to highlight it in the Navigation pane.

28 On the toolbar, click to resize the detail to fit in the right pane.

29 Click , and move the cursor in the right pane to spin the detail in the right pane.

30 Click , right-click the roofing in the detail in the right pane, and click Transparent.

31 Close the viewer.
Lesson 4: Updating and Modifying Project Tools

In this lesson, you learn how to update and modify project-specific tools. This project contains a tool palette group, Steel-Framed Residence_M, that includes a tool palette named Structural Member Styles. This tool palette contains the structural members tools (beams, braces, and columns) that you used to complete the exercises in this tutorial. The project tools reference a standards drawing (Styles_STD.dwg) stored in the project structure that contains project-specific styles and definitions.

In the first exercise in this lesson, you create a new column tool on the Structural Member Styles palette. You create the column in a project drawing, and then update the project standards with the style of the new column. This process is useful on projects with multiple members, where a member of a project team might create a tool with a new style or definition in a project drawing.

In the second exercise, you modify the new column tool that you create. Because structural members are a single object type (structural member) and are defined as beams, braces, or columns at a sub-object level, all new tools are created as structural members. You need to change the properties of each tool to specify whether it is a beam, brace, or column. You also learn how to change the appearance of the tools on the palette, which applies to all tool types, not just structural members.

Exercise 1: Updating Project-Standard Tools

In this exercise, you learn how to add a new project standard tool to the Structural Member Styles tool palette. You create a new column in a project drawing, update the project standards with the style of the column from the drawing, and then create a new column tool on the Structural Member Styles tool palette. The new column tool references the style stored in the project standards drawing.

View the project standard style and definition types

1. With the Project Navigator open, click the Project tab.
2. Click [ ] in the Current Project title bar.
3. At the bottom of the Modify Project worksheet, click Configure for Project Standards.
4. On the Configure AEC Project Standards worksheet, click the Standard Styles tab.
5. Verify that All Objects is selected in the Select which objects to display list.
6. In the table, scroll to view which style and definition types reference the standards drawing, Styles_STD.dwg.
7. Click Cancel twice.
8. Add a column with a new style to a project drawing
   With the Project Navigator open, click Constructs tab.
9. Under the Constructs folder, double-click House Structure to open it in the drawing area.
10. On the Navigation toolbar, click [ ] to access the Content Browser.

NOTE: Do not access the Content Browser by clicking the icon in the Project Navigator. The icon in the Project Navigator accesses a project-specific library only. You want to access the general library to locate a column that is not in the current project.

11. In the Content Browser, under Search, enter precast column, and click GO.
12. On the Search Results page, locate Precast Column 400x400 I Haunch.
13. Click and drag the Precast Column 400x400 I Haunch i-drop icon [ ] to the drawing area.
   The Properties palette displays the default properties for the column.
14. Specify an insertion point anywhere in the drawing, and press ENTER to use the default roll value to create a column.
15. Press ENTER to end the command.
16. Close the Content Browser.
17. On the File menu, click Save.
   The new column (and its style) is saved in the drawing.
18. Update the project standard styles drawing from the House Structure drawing.
19 Expand STL101-Steel-Framed_M.
   The project styles standards drawing, Styles_STD.dwg, is displayed.

20 Expand Styles_STD.dwg, and expand Architectural Objects.
   The style types listed under Architectural Objects with blue icons next to them contain standard styles. These are
   the style types that you viewed on the Configure AEC Project Standards worksheet.

21 Expand Structural Member Styles.
   The structural members styles icons are displayed as blue, indicating they are project standard styles.

22 Select Structural Member Styles, right-click, and click Update from Current Drawing.
   The Update Project Standards worksheet is displayed. The lower half of the worksheet lists the new structural
   member style as not present in the project standards (the Styles_STD.dwg).

23 Under Action, verify Add to Project Standards is selected, and click OK.

24 In the Style Manager, notice that the Precast Column 400x400 I Haunch is displayed under Structural Member
   Styles. Its icon is displayed as blue, indicating it is a project standard style.

25 Click OK to exit the Style Manager.

26 When prompted to save changes to the Styles_STD.dwg, click Yes.
   Next, you create a precast column tool on the Structural Member Styles palette that references the style that you
   just added to project standards drawing.

27 Update the project catalog
   If the CAD Manager menu is not displayed on the menu bar, on the Window menu, click Pulldowns ➤ CAD
   Manager Pulldown.

28 On the CAD Manager menu, select Tool Catalog Generator.

29 On the Populate Tool Catalog from Content Drawings worksheet, under Catalog, select Add to an existing catalog.

30 Under Type the location of the catalog, click Browse to specify Steel-Framed Residence_M.atc, located by default
   in c:\my documents\autodesk\my projects\steel-framed residence_M.

31 Select Append to Catalog and Ignore duplicate styles.

32 Under Content Source, select Create from drawing, and click Browse.
   Browse toc:\my documents\autodesk\my projects\steel-framed residence_M\standards\object styles, select Styles_STD.dwg,
   and click Open.

   To ensure consistent standards in the project, you want to be careful to create tools from the project standards
   style drawing, not from any of the individual project drawings.

34 Under Tool Organization, select Group tools by object type and Create tools in Palettes.

35 Under Create tools for the following objects, click Clear all, and select Structural Member Styles.

36 Click OK.

37 On the Overwrite warning worksheet, click Yes to replace the ATC file.
   This file is the current tool catalog for the project.

38 Click Yes to create the catalog in the current tool palette set location.

39 Click OK.

40 Add a new Precast Column tool to the Structural Members tool palette
   On the Project Navigator, click the Project tab.

41 At the bottom of the Project Navigator, click .

42 In the Content Browser, double-click the project library, Steel-Framed Residence_M.

43 Double-click Structural Member Styles.

NOTE: Notice that all the tool images for the structural members styles all have the same orientation. The tool images
for columns are oriented as if they were beams. Because structural members are the same object type, all structural
members tools are created as beams by default. You need to modify them, which you will do in the next exercise.

45 On the File menu, click Save, and continue to the next exercise to make some modifications to the structural
member tools that you created.
Exercise 2: Modifying Structural Member Tools

In this exercise, you modify the Precast Column tool that you added on the Structural Member Styles palette in the previous exercise. When you create structural member tools, there are a few modifications that you need to make to the tools. Because structural members are the same object type, all structural members tools are created as beams by default. In this exercise, you manually change the member type property of the Precast Column tool to assign it the appropriate behavior and orientation. You also need to modify the tool image of the Precast Column to accurately reflect the type of member that it creates. You update the tool image from a precast column that you create in the drawing.

Change the Precast Column tool member properties

1. On the Structural Member Styles tool palette, right-click the Precast Column 400x400 I Haunch tool, and click Properties.
2. At the top of the Tool Properties worksheet, click in the Description field.
3. On the Description worksheet, enter Creates a 400x400 I Haunch precast column, and click OK.
4. Verify that Precast Column 400x400 I Haunch is displayed for Style.
5. Verify that the Style location is the Styles_STD.dwg.
The tool is referencing the standards drawing for its style.
6. Under General, select Column for Member Type.
   You changed the member type for the column, but the tool image is still oriented as if it were a beam.
7. Under Dimensions, select Middle Center for Justify.
8. Scroll down to the Viewer, right-click on the tool image in the viewer, and click Preset Views ➤ SW Isometric.
   This is where you define the view direction of the tool image. Next, you will update the image itself from a column that you create in the drawing.
9. Click OK.
10. Update the tool image from a column in the drawing
   On the Structural Member Styles tool palette, click Precast Column 400x400 I Haunch.
11. Specify an insertion point anywhere in the drawing, and press ENTER to use the default roll value to create the column.
12. Press ENTER to end the command.
13. Select the column to display the column grips.
14. Select and move the Lengthen grip downward to reduce the size of the column.
   Reducing the size of the column provides a clear shape for the tool image.
15. On the Structural Member Styles palette, right-click Precast Column 400x400 I Haunch, and click Set Image from Selection.
16. Select the precast column in the drawing, and press ENTER.
   The Precast Column 400x400 I Haunch tool image updates to include the representation of the beam that you selected in the drawing. If the image does not display as desired on the tool palette, resize the column, and reset the tool image.
17. On the File menu, click Save, and close the drawing.
The Precast Column 400x400 I Haunch tool is updated and is part of the Steel-Framed Residence tool palette group. All of the tools on this palette are referencing the project standards drawing, Styles_STD.dwg, for their styles.